Results 1 to 19 of 19

Thread: problem loading custom plugin on Qt Designer 4

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default problem loading custom plugin on Qt Designer 4

    Hi All,
    I have installed a plugin in Qt Designer which has generated libmywidgetplugin.so in the /root/qtopia-core-opensource-src-4.3.3/plugins/designer folder.Now when I open the Qt Designer program the plugin fails to load.The plugin information window shows this:

    Ths plugin 'The plugin '/usr/lib/qt4/plugins/designer/libmywidgetplugin.so' uses incompatible Qt library. (4.3.3) [release]''

    Any idea what the problem could be ?
    I am using Qtopia4.3.3 and Qt Designer4 here.

    Thanks,
    raman

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: problem loading custom plugin on Qt Designer 4

    Is the designer built in release mode?

  3. #3
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: problem loading custom plugin on Qt Designer 4

    Hello,
    I didnt build the designer from source.I installed the desginer using

    yum install qt4-designer
    The version installed is 4.3.2 open source edition.This version is working fine.I have created some applications using this and Qtopia 4.3.3.But somehow the plugin doesnt load.
    How do I know about release mode stuff?

    Thanks,
    raman

  4. #4
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: problem loading custom plugin on Qt Designer 4

    If the designer is for Qt 4.3.2 and the plugin for Qtopia 4.3.3 then they are incompatible. You need to build the plugin for Qt 4.3.2 to run it in your Designer.

  5. #5
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: problem loading custom plugin on Qt Designer 4

    Thanks for the suggestion.......I missed out this point on loading plugins in the Qt Designer manual....I dont want to downgrade my Qtopia 4.3.3 installation....I am trying to upgrade Qt Designer 4.3.2 to 4.3.3 but I am unable to find this version for fedora 6 OS....I cant afford to upgrade my PC to fedora 7 as that will be a long procedure....is there Qt Designer 4.3.3 version for fedora 6???

    thanks,
    raman

  6. #6
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: problem loading custom plugin on Qt Designer 4

    Why not compile Qt from sources? It's a straightforward process, you will surely manage it.

  7. #7
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: problem loading custom plugin on Qt Designer 4

    I had installed qtopia by building qtopia-core-opensource-src-4.3.3.tar from source but I dont think that Qt designer 4.3.3. comes as a part of this source file.

    I had to install Qt designer 4 separately using yum command later.Is there any latest source file which has all the Qt packages in it...i.e. Qtopia,Qt designer,Qt assistant,Qt linguist??
    thanks,
    raman

  8. #8
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: problem loading custom plugin on Qt Designer 4

    Take a look at the main page of this site. There is a link there that will take you to Qt downloads. Alternatively you can find similar links on trolltech.com

  9. #9
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: problem loading custom plugin on Qt Designer 4

    Thanks all for your suggestions!

    I have now upgraded to Fedora 9 and installed Qtopia 4.3.5 and Qt Designer 4.3.5.
    Now I have created a plugin using the examples , compiled ("make") and installed using
    make install
    The .so file installs at /usr/local/Trolltech/QtopiaCore-4.3.5/plugins/designer/libmywidgetplugin.so

    But the problem is the plugin doesnt load on the Qt Desginer.Is there anything left to be done?
    These are contents of the plugin folder

    [root@localhost designer]# ls
    libcontainerextension.so libqt3supportwidgets.so.debug
    libcontainerextension.so.debug libtaskmenuextension.so
    libcustomwidgetplugin.so libtaskmenuextension.so.debug
    libcustomwidgetplugin.so.debug libworldtimeclockplugin.so
    libmywidgetplugin.so libworldtimeclockplugin.so.debug
    libqt3supportwidgets.so
    thanks,
    raman

  10. #10
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: problem loading custom plugin on Qt Designer 4

    Run designer, open its "About Plugins" dialog box and see what is the error associated with the plugin.

  11. #11
    Join Date
    Feb 2008
    Posts
    46
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: problem loading custom plugin on Qt Designer 4

    Hello,
    Earlier this plugin had installed at /usr/local/Trolltech/QtopiaCore-4.3.5/plugins/designer which I later realised is not the path designer expects the plugins to be in since it was not loacting it.

    So I copied the plugins to
    /usr/lib/qt4/plugins/designer

    When I run the designer I get this error
    QLibrary:: load_sys : Cannot load /usr/lib/qt4/plugins/designer/libmywidgetplugin.so(/usr/lib/qt4/plugins/designer/libmywidgetplugin.so: undefined symbol: _ZN7QWidget8qwsEventEP8QWSEvent)

    I have attached my source files for the plugin. mywidget.zip
    Attached Files Attached Files
    thanks,
    raman

Similar Threads

  1. plugin loading problem
    By naresh in forum Qt Programming
    Replies: 6
    Last Post: 9th June 2007, 19:05
  2. Testing a custom Plugin
    By maluta in forum Qt Programming
    Replies: 5
    Last Post: 31st October 2006, 15:09
  3. Custom plugin for a layout
    By cocheci in forum Qt Tools
    Replies: 2
    Last Post: 12th June 2006, 18:36
  4. Replies: 16
    Last Post: 7th March 2006, 15:57
  5. Replies: 4
    Last Post: 1st March 2006, 23:11

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.