Results 1 to 5 of 5

Thread: Error when compiling for static version in windows

  1. #1
    Join Date
    Sep 2008
    Posts
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Error when compiling for static version in windows

    Hi i was trying to compile a static version of qt 4.4.1 for windows xp sp 3 using the mingw32

    i follow this procedure

    • install 4.4.1
    • modify \mkspecs\win32-g++\qmake.conf to include the -static reference
      "QMAKE_LFLAGS = -static -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc"
    • configure using command: "configure -static -release -no-exceptions -webkit -assistant-webkit"
    • run "make sub-src", which seems to finish okay
    • then try to run "make install" but then i get an error when it tries to compile assistant


    i have included errors in the zip file

    Any help in helping me solve this problem would be appreciated
    Attached Files Attached Files

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: Error when compiling for static version in windows

    You cannot link Webkit (nor Phonon) statically as they are LGPL libraries.
    J-P Nurmi

  3. #3
    Join Date
    Oct 2006
    Location
    Germany
    Posts
    84
    Thanks
    5
    Thanked 5 Times in 3 Posts
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Error when compiling for static version in windows

    Actually, I have linked WebKit statically into my application. It worked right out of the box. I'm not sure about Phonon though as I have never used it.

  4. #4
    Join Date
    Oct 2008
    Posts
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Error when compiling for static version in windows

    Quote Originally Posted by durbrak View Post
    Actually, I have linked WebKit statically into my application. It worked right out of the box. I'm not sure about Phonon though as I have never used it.
    durbrak: Can you please describe how did you managed that (some special flags in .pro or configuration or something like that)? With MinGW and Windows i have the same errors like described.

    jpn: LGPL should not be an problem in a GPL-build.

  5. #5
    Join Date
    Jun 2006
    Posts
    64
    Thanks
    10
    Thanked 3 Times in 3 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Error when compiling for static version in windows

    For what its worth I followed the procedure at:

    http://rag.com.au/linux/qt4howto.html

    and it worked for me.

    Regards, B1.

Similar Threads

  1. Designer doesn't load wwWidgets plugin
    By reimer in forum Installation and Deployment
    Replies: 21
    Last Post: 7th February 2009, 03:23
  2. Qt designer plugin errors on OSX Leopard
    By mpotocnik in forum Qt Tools
    Replies: 10
    Last Post: 21st January 2008, 09:45
  3. Distributing QT application for Mac OS
    By mb0 in forum Qt Programming
    Replies: 1
    Last Post: 31st May 2007, 18:59
  4. Replies: 15
    Last Post: 21st April 2007, 17:46

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.