Results 1 to 5 of 5

Thread: Problem installing Qt4.4 x11 on RHEL 4

  1. #1
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Question Problem installing Qt4.4 x11 on RHEL 4

    Dear All,

    I had Qt4.3.1 opensource for x11 installed on RHEL 4 successfully,

    and when I tried to install qt-x11-commercial-src-4.4.0

    - configuration with ( ./configure ) passed succesfully
    - but when I ran gmake and after a while I had the following error:

    ....
    .....
    cd src/3rdparty/webkit/WebCore/ && gmake -f Makefile
    gmake[1]: Entering directory `/root/qt-x11-commercial-src-4.4.0/qt-x11-commercial-src-4.4.0/src/3rdparty/webkit/WebCore'
    gcc -c -include .pch/release-shared/QtWebKit -pipe -g -O2 -D_REENTRANT -fPIC -DQT_SHARED -DQT_EDITION=QT_EDITION_DESKTOP -DBUILDING_QT__=1 -DUSE_SYSTEM_MALLOC -DNDEBUG -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DHAVE_STDINT_H -DBUILD_WEBKIT -DENABLE_ICONDATABASE=1 -DENABLE_XPATH=1 -DENABLE_SVG=1 -DWTF_CHANGES=1 -DBUILDING_QT__ -DWTF_USE_JAVASCRIPTCORE_BINDINGS=1-DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE-D_LARGEFILE_SOURCE -I../../../../mkspecs/linux-g++ -I. -I../../../../include/QtCore -I../../../../include/QtCore -I../../../../include/QtNetwork -I../../../../include/QtNetwork -I../../../../include/QtGui -I../../../../include/QtGui -I../../../../include -I../WebKit/qt/Api -I../JavaScriptCore -I../JavaScriptCore/kjs -I../JavaScriptCore/bindings -I../JavaScriptCore/bindings/c -I../JavaScriptCore/wtf -I../JavaScriptCore/ForwardingHeaders -I. -IForwardingHeaders -Iplatform -Iplatform/network -Iplatform/graphics -Iloader -Ipage -Icss -Idom -Ibridge -Iediting -Irendering -Ihistory -Ixml -Ihtml -Iplugins -I../../../../include/QtWebKit -I.rcc/release-shared -Igenerated -Itmp -I../JavaScriptCore -I../JavaScriptCore/kjs -I../JavaScriptCore/bindings -I../JavaScriptCore/bindings/c -I../JavaScriptCore/wtf -I../JavaScriptCore/bindings/qt -I../JavaScriptCore/pcre -I/root/qt-x11-commercial-src-4.4.0/qt-x11-commercial-src-4.4.0/src/3rdparty/webkit/WebKitBuild/Debug/JavaScriptCore/kjs/tmp -Iplatform/qt -Iplatform/network/qt -Iplatform/graphics/qt -Iplatform/graphics/svg/qt -Iloader/qt -Ipage/qt -I../WebKit/qt/WebCoreSupport -I../WebKit/qt/Api -I. -IForwardingHeaders -I../../webkit -I../JavaScriptCore/kjs -I../JavaScriptCore/bindings -Iplatform -Iplatform/network -Iplatform/graphics -Iplatform/graphics/svg -Iplatform/graphics/svg/filters -Iloader -Iloader/icon -Icss -Idom -Ipage -Ibridge -Iediting -Irendering -Ihistory -Ixml -Ihtml -Ibindings/js -Iksvg2 -Iksvg2/css -Iksvg2/svg -Iksvg2/misc -Iksvg2/events -Iplatform/image-decoders -I../../sqlite -I.moc/release-shared -I.uic/release-shared -o .obj/release-shared/sqlite3.o ../../sqlite/sqlite3.c
    ../../sqlite/sqlite3.c:68533:34: invalid suffix "include" on integer constant
    ../../sqlite/sqlite3.c:68533:42: warning: null character(s) ignored
    ../../sqlite/sqlite3.c:68533: error: initializer element is not constant
    ../../sqlite/sqlite3.c:68533: error: (near initialization for `yy_default[583]')
    ../../sqlite/sqlite3.c:68533: error: syntax error before "endif"
    ../../sqlite/sqlite3.c:68533:48: warning: null character(s) ignored
    ../../sqlite/sqlite3.c:68533:56: warning: null character(s) ignored
    ../../sqlite/sqlite3.c:68533:63: warning: null character(s) ignored
    ../../sqlite/sqlite3.c:68533:73: warning: null character(s) ignored
    I don't know what's exactly the problem, but it looks like there is a conflict in either sqlite3 or the webkit installation.

    please, help.

    Thanks in advance.
    Last edited by jpn; 2nd December 2008 at 18:50. Reason: missing [quote] tags

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: Problem installing Qt4.4 x11 on RHEL 4

    Which gcc version do you have? WebKit supports only 3.4 and newer.
    J-P Nurmi

  3. #3
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Problem installing Qt4.4 x11 on RHEL 4

    I have:
    gcc version 3.4.3 20041212 (Red Hat 3.4.3-9.EL4)

  4. #4
    Join Date
    May 2008
    Location
    Kyiv, Ukraine
    Posts
    418
    Thanks
    1
    Thanked 29 Times in 27 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: Problem installing Qt4.4 x11 on RHEL 4

    When you run configure script, did you specify that qt should use system sqlite or the one that is inside qt's sources?
    I'm a rebel in the S.D.G.

  5. #5
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Problem installing Qt4.4 x11 on RHEL 4

    sorry for the late reply.

    No I didn't specify whether to use system sqlite or qt's one.

    to complete my task, I did run
    Qt Code:
    1. make confclear
    To copy to clipboard, switch view to plain text mode 
    and installed the open-source version of Qt4.4.3 x11 and it did work perfectly.

    But I still want to know what to do about that problem to complete the original.

    thank you very much.

Similar Threads

  1. problem installing QT4 on Linux
    By p_kian in forum Installation and Deployment
    Replies: 8
    Last Post: 13th April 2011, 13:17
  2. Qt4.4 / STLPort / MSVC-2005 -- installation problem
    By hbrt in forum Installation and Deployment
    Replies: 0
    Last Post: 3rd October 2008, 10:41
  3. Friends Problem in Installing Qt 4.3.2 on Mac Os X
    By nareshqt in forum Installation and Deployment
    Replies: 1
    Last Post: 11th April 2008, 06:35
  4. Qt4.4 on Mac, pro problem
    By bnilsson in forum Installation and Deployment
    Replies: 1
    Last Post: 21st March 2008, 09:07
  5. Qt 4.2.2 not installing in RHEL 9
    By deepakn in forum Installation and Deployment
    Replies: 3
    Last Post: 12th December 2007, 11:20

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.