Results 1 to 6 of 6

Thread: Qt 4.4.3 commercial on Kubuntu 8.10

  1. #1
    Join Date
    Jun 2007
    Posts
    56
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default Qt 4.4.3 commercial on Kubuntu 8.10

    I recently installed Kubuntu 8.10 with KDE 4 on a server here at work. I then installed our commercial version of qt-X11-4.4.3. It built and installed with no problems.

    When I run the qtdemo though, it doesn't do the animated main screen and the rendering of the text looks like crap. Any ideas on what would be causing this?

    Thanks,
    -Mic

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: Qt 4.4.3 commercial on Kubuntu 8.10

    Make sure you have suitable dev packages installed while configuring Qt. The configure script outputs detailed information after compiling qmake. Probably installing libfontconfig-dev, reconfiguring and recompiling Qt helps.
    J-P Nurmi

  3. #3
    Join Date
    Jun 2007
    Posts
    56
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default Re: Qt 4.4.3 commercial on Kubuntu 8.10

    Quote Originally Posted by jpn View Post
    Make sure you have suitable dev packages installed while configuring Qt. The configure script outputs detailed information after compiling qmake. Probably installing libfontconfig-dev, reconfiguring and recompiling Qt helps.
    Here is the output of the configure script. Can anyone spot what might cause the animated start up and crappy font rendering not work?

    Build type: linux-g++
    Architecture: i386
    Platform notes:

    - Also available for Linux: linux-kcc linux-icc linux-cxx

    Build ............... libs tools examples demos docs translations
    Configuration ....... release shared dll largefile stl precompile_header separate_debug_info mmx 3dnow sse sse2 qt3support accessibility minimal-config small-config medium-config large-config full-config reduce_exports ipv6 clock-gettime clock-monotonic mremap getaddrinfo ipv6ifname getifaddrs inotify png freetype system-zlib nis iconv glib xshape xkb xmlpatterns svg webkit release
    Debug ............... no
    Qt 3 compatibility .. yes
    QtDBus module ....... no
    QtXmlPatterns module yes
    Phonon module ....... no
    SVG module .......... yes
    WebKit module ....... yes
    WebKit in Assistant no
    STL support ......... yes
    PCH support ......... yes
    MMX/3DNOW/SSE/SSE2.. yes/yes/yes/yes
    IPv6 support ........ yes
    IPv6 ifname support . yes
    getaddrinfo support . yes
    getifaddrs support .. yes
    Accessibility ....... yes
    NIS support ......... yes
    CUPS support ........ no
    Iconv support ....... yes
    Glib support ........ yes
    GStreamer support ... no
    Large File support .. yes
    GIF support ......... plugin
    TIFF support ........ plugin (qt)
    JPEG support ........ plugin (qt)
    PNG support ......... yes (qt)
    MNG support ......... plugin (qt)
    zlib support ........ system
    OpenGL support ...... no
    NAS sound support ... no
    Session management .. no
    XShape support ...... yes
    Xinerama support .... no
    Xcursor support ..... no
    Xfixes support ...... no
    Xrandr support ...... no
    Xrender support ..... no
    FontConfig support .. no
    XKB Support ......... yes
    immodule support .... yes
    SQLite support ...... plugin (qt)
    OpenSSL support ..... no


    I've since installed libfontconfig1-dev which also installed freetype-dev and xpat-dev.

    Any help is appreciated.
    -Mic

  4. #4
    Join Date
    Jun 2007
    Posts
    56
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default Re: Qt 4.4.3 commercial on Kubuntu 8.10

    Actually, I punted this morning and installed ubuntu 8.04 and re-installed qt-4.4.3. The configure output above is actually from that build. It still has the same problem with the animation not working and the test looking like crap.

    -Mic

  5. #5
    Join Date
    Jun 2007
    Posts
    56
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Talking Re: Qt 4.4.3 commercial on Kubuntu 8.10

    I solved the puzzle. I needed to install lots more X11 things such as xrandr, xcursor, xrender and such. Basically when configure said that something wasn't enabled, I installed it. I also installed OpenGL but I don't know which one of these solved the problem I was experiencing.

  6. #6
    Join Date
    Feb 2010
    Posts
    10
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Question Re: Qt 4.4.3 commercial on Kubuntu 8.10

    Quote Originally Posted by Micawber View Post
    I solved the puzzle. I needed to install lots more X11 things such as xrandr, xcursor, xrender and such. Basically when configure said that something wasn't enabled, I installed it. I also installed OpenGL but I don't know which one of these solved the problem I was experiencing.

    Hi there, can you tell me where you go about installing those missing X11 libraries? xrender, xrandr, xcursor, xfixes, and xinerama to be exact. I'm having problem finding those X11 libraries for my system.(Solaris 8, SPARC, g++ compiler)

    thanks

    ML

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.