Results 1 to 2 of 2

Thread: DBus Registration problem

  1. #1
    Join Date
    Sep 2008
    Qt products

    Post DBus Registration problem

    I am using dbus to communicate two different process ./Qt (GUI)and ./Mymain(non GUI)

    I have registered Object and registered the service(name- com.nirav.test at path- /aa) in ./Qt .

    Then I have created Interface of this service name in ./Mymain. I am calling function of ./Qt from ./Mymain using ... ).

    So till Now I have been able to communicate from ./Mymain to ./Qt. using dbus interface.

    my aim is to intimate ./Mymain when ever any button clicked in ./Qt.

    Now I have register object in ./Mymain at path /aa/bb. when i run my ./Mymain object get registered.(I have used debug to check whether object registered or not)

    But when I run qdbusvewier It show only the slot registered for object in ./Qt process at path /aa.
    It doen't show slots of object i have register in ./Mymain at /aa/bb.

    I dont know what wrong with it..

    My class declaration is as below,

    Mydata : public QObject
    // Constructor and destructor
    public slots:
    // name of the slots


    I am directly registing this object without mashalling or demarshalling(Is it needed ?),and alos i have not used QCoreApplication(argc, argv) or QApplication(argc, argv) in my ./Mymain.

    Please help me....

  2. #2
    Join Date
    Jan 2006
    Alingsås, Sweden
    Thanked 39 Times in 39 Posts
    Qt products
    Qt3 Qt4
    Unix/X11 Windows

    Default Re: DBus Registration problem

    This is a duplicate, please don't double post:

Similar Threads

  1. DBus over Network?
    By shensel in forum Qt Programming
    Replies: 5
    Last Post: 26th March 2009, 11:12
  2. Weird problem: multithread QT app kills my linux
    By Ishark in forum Qt Programming
    Replies: 2
    Last Post: 8th August 2008, 09:12
  3. DBus daemon not starting
    By Khal Drogo in forum Qt Programming
    Replies: 5
    Last Post: 7th August 2008, 15:12
  4. Steps in solving a programming problem?
    By triperzonak in forum General Programming
    Replies: 8
    Last Post: 5th August 2008, 08:47
  5. Replies: 16
    Last Post: 7th March 2006, 15:57


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.