Results 1 to 2 of 2

Thread: Weird Windows Vista Permissions Causing Qmake Crash

  1. #1
    Join Date
    Jun 2009
    Posts
    1
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Weird Windows Vista Permissions Causing Qmake Crash

    Hi all,

    This caused me enough sorrow and pain to figure out that I'm compelled to write it up in hopes that the next poor guy this happens to has some help. If I was blind in searching for this resolution and I'm making a redundant post, please just get rid of this one.

    Recently, I was forced to turn my Vista laptop into a development box. Qt build crashed trying to run qmake on the PostgreSQL 8.3 plugin. I reconfigured without that and everything was okay. But, I NEEDED that plugin. Qmake would crash every time I ran this:

    qmake "INCLUDEPATH+=C:\psql\include" "LIBS+=C:\psql\lib\ms\libpq.lib" psql.pro
    Stepping into the debugger, it bombed out in some windows native code, dbghook.c:

    Qt Code:
    1. __declspec(noinline)
    2. void __cdecl _CRT_DEBUGGER_HOOK(int _Reserved)
    3. {
    4. /* assign 0 to _debugger_hook_dummy so that the function is not folded in retail */
    5. (_Reserved); << _Reserved could not be evaluated
    6. _debugger_hook_dummy = 0;
    7. }
    To copy to clipboard, switch view to plain text mode 

    Mildly disconcerting. If I ran qmake without configuring the includepath, it would make it through, but then nmake would complain that it didn't know about "libpq-fe.h" and finally I got wise and tried to open libpq-fe.h to see what was wrong in there. libpq-fe.h, and actually every single header in the postgres include directory, crashed Notepad++. Wordpad and Visual Studio opened them just fine, though.

    Five or six dialog boxes deep into libpq-fe.h's windows permissions, it seemed that PostgreSQL's service user account was the owner, and even though my local user account was an admin, it seems like I was getting bitten by some very strange permissions issue in Vista.

    The Solution: Copy C:\psql\include to the desktop, delete the original C:\psql\include, and drop the copy back into C:\psql\. At which time I died laughing.

    Take care,

    -Rob

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,014 Times in 4,792 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Weird Windows Vista Permissions Causing Qmake Crash

    ...or disable UAE (I don't mean "Unix Amiga Emulator") or whatever the Vista permission gaining system was called (I don't remember the weird mnemonic...).
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.