Results 1 to 10 of 10

Thread: Install Qt 4.5 with phonon support

  1. #1
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Install Qt 4.5 with phonon support

    Hello,
    First, I am sorry for repeat this post. I did not put in the correct place.

    I have qt 4.5 and I would like to configure with phonon support (./configure -phonon).
    Well, If I do it in a desktop with Opensuse 32 bits (./configure -phonon -force-pkg-config), it works fine.
    But If I do it in a desktop with Opensuse 64 bits, the same comand return me a error, because it can not compile config.test/unix/glib.
    If I delete option -phonon, I can configure and compile Qt 4.5 without problems.
    My target is 32 bits.

    Best regards.

  2. #2
    Join Date
    Aug 2008
    Location
    Ukraine, Krivoy Rog
    Posts
    1,963
    Thanked 370 Times in 336 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    did you install x32 libs on OpenSuSE x64? I compiled on OpenSuSE x64 Qt 4.5.3 with phonon and did not get any errors.
    Qt Assistant -- rocks!
    please, use tags [CODE] & [/CODE].

  3. The following user says thank you to spirit for this useful post:

    webquinty (10th December 2009)

  4. #3
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Quote Originally Posted by spirit View Post
    did you install x32 libs on OpenSuSE x64? I compiled on OpenSuSE x64 Qt 4.5.3 with phonon and did not get any errors.
    Yes, I have it. In my hard disk there are two folders, /lib and /lib64 and /usr/lib and /usr/lib64.
    For example, in /usr/lib I have the follow files:

    Linux-D530:/usr/lib/pkgconfig # ls -la
    total 68
    drwxr-xr-x 2 root root 4096 dic 10 12:03 .
    drwxr-xr-x 104 root root 32768 dic 10 12:03 ..
    -rw-r--r-- 1 root root 213 jun 6 2008 glib.pc
    -rw-r--r-- 1 root root 210 jun 6 2008 gmodule.pc
    -rw-r--r-- 1 root root 212 jun 6 2008 gthread.pc
    -rw-r--r-- 1 root root 244 nov 12 13:25 libcrypto.pc
    -rw-r--r-- 1 root root 259 nov 12 13:25 libssl.pc
    -rw-r--r-- 1 root root 210 abr 14 2009 libvolume_id.pc
    -rw-r--r-- 1 root root 269 nov 12 13:25 openssl.pc
    -rw-r--r-- 1 root root 231 jun 7 2008 sqlite.pc
    But, as I can see, I dont see glib-2.0 and gthread-2.0...........
    Perhaps you are right, I hava not install correct version of glib and gthread. I am going to check it.

    Thank you very much.

  5. #4
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Ok,

    I have not correct .pc files to glib-2.0 and some problem with symbolic links.

    Thank you very much. Now compiling Qt 4.5 with phonon support.

  6. #5
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Well,

    another problem, after compile Qt with phonon support without problems, I made "make install" and install it in /opt/Qt folder.

    drwxr-xr-x 10 sshd 0 1024 Jan 18 15:19 .
    drwxr-xr-x 5 sshd 0 1024 Jan 18 15:19 ..
    drwxr-xr-x 2 sshd 0 1024 Jan 18 15:19 bin
    drwxr-xr-x 19 sshd 0 1024 Jan 18 15:19 demos
    drwxr-xr-x 26 sshd 0 1024 Jan 18 15:19 examples
    drwxr-xr-x 15 sshd 0 1024 Jan 18 15:19 include
    drwxr-xr-x 4 sshd 0 2048 Jan 18 15:19 lib
    drwxr-xr-x 88 sshd 0 3072 Jan 18 15:19 mkspecs
    drwxr-xr-x 7 sshd 0 1024 Jan 18 15:19 plugins
    drwxr-xr-x 2 sshd 0 1024 Jan 18 15:19 translations
    and my environment variables:

    export QTDIR=/opt/Qt
    export LD_LIBRARY_PATH=$QTDIR/lib:/usr/lib:/lib
    export POINTERCAL_FILE=/mnt/hdd1/touch_conf/pointercal
    export QWS_MOUSE_PROTO=tslib:/dev/input/event0
    export QWS_DISPLAY="VNC:LinuxFb"
    .pro file:

    TEMPLATE = app
    TARGET = prueba
    QT += core \
    gui \
    phonon
    HEADERS += window.h
    SOURCES += window.cpp \
    main.cpp
    FORMS += prueba.ui
    RESOURCES +=
    When I try to execute a phonon example, ./capabilities -qws, there are some errors:

    #./capabilities -qws
    WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
    WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
    WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
    And the content of .Qt/

    # ls
    bin examples lib plugins
    demos include mkspecs translations
    # cd plugins/
    # ls
    accessible iconengines imageformats phonon_backend sqldrivers
    # cd phonon_backend/
    # ls
    libphonon_gstreamer.so
    So, I dont understand what is the problem.

    Best reagards.
    Last edited by webquinty; 11th December 2009 at 10:08.

  7. #6
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Hello,

    I found some problems with shared libraries. Now, new situation:

    # ./capabilities -qws
    "Warning: You do not seem to have the base GStreamer plugins installed.
    All audio and video support has been disabled"
    Phonon::GStreamer::Backend: Failed to initialize GStreamer
    any advice?

  8. #7
    Join Date
    Aug 2008
    Location
    Ukraine, Krivoy Rog
    Posts
    1,963
    Thanked 370 Times in 336 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    do you have installed gstream libraries?
    Qt Assistant -- rocks!
    please, use tags [CODE] & [/CODE].

  9. #8
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Hello,
    In /usr/lib I have follow files:

    john@Linux-D530:/usr/lib> ls -la libgs*

    lrwxrwxrwx 1 root root 21 abr 10 2009 libgssapi_krb5.so -> libgssapi_krb5.so.2.2
    lrwxrwxrwx 1 root root 21 abr 10 2009 libgssapi_krb5.so.2 -> libgssapi_krb5.so.2.2
    -rwxr-xr-x 1 root root 178920 abr 6 2009 libgssapi_krb5.so.2.2
    lrwxrwxrwx 1 root root 16 abr 10 2009 libgssrpc.so.4 -> libgssrpc.so.4.0
    -rwxr-xr-x 1 root root 104876 abr 6 2009 libgssrpc.so.4.0
    lrwxrwxrwx 1 root root 21 dic 10 17:45 libgstaudio-0.10.so -> libgstaudio-0.10.so.0
    lrwxrwxrwx 1 root root 26 dic 9 17:19 libgstaudio-0.10.so.0 -> libgstaudio-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 114188 jun 7 2008 libgstaudio-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 20 dic 10 15:15 libgstbase-0.10.so -> libgstbase-0.10.so.0
    lrwxrwxrwx 1 root root 25 may 20 2009 libgstbase-0.10.so.0 -> libgstbase-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 175612 jun 7 2008 libgstbase-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 25 dic 9 17:19 libgstcdda-0.10.so.0 -> libgstcdda-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 43732 jun 7 2008 libgstcdda-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 26 may 20 2009 libgstcheck-0.10.so.0 -> libgstcheck-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 26608 jun 7 2008 libgstcheck-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 31 may 20 2009 libgstcontroller-0.10.so.0 -> libgstcontroller-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 147004 jun 7 2008 libgstcontroller-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 33 may 20 2009 libgstdataprotocol-0.10.so.0 -> libgstdataprotocol-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 18240 jun 7 2008 libgstdataprotocol-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 24 dic 9 17:19 libgstfft-0.10.so.0 -> libgstfft-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 43656 jun 7 2008 libgstfft-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 26 dic 10 15:14 libgstinterfaces-0.10.so -> libgstinterfaces-0.10.so.0
    lrwxrwxrwx 1 root root 31 dic 9 17:19 libgstinterfaces-0.10.so.0 -> libgstinterfaces-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 44064 jun 7 2008 libgstinterfaces-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 24 may 20 2009 libgstnet-0.10.so.0 -> libgstnet-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 27076 jun 7 2008 libgstnet-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 30 dic 9 17:19 libgstnetbuffer-0.10.so.0 -> libgstnetbuffer-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 9988 jun 7 2008 libgstnetbuffer-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 28 dic 9 17:19 libgstpbutils-0.10.so.0 -> libgstpbutils-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 47524 jun 7 2008 libgstpbutils-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 22 dic 10 15:11 libgstreamer-0.10.so -> libgstreamer-0.10.so.0
    lrwxrwxrwx 1 root root 27 may 20 2009 libgstreamer-0.10.so.0 -> libgstreamer-0.10.so.0.16.0
    -rwxr-xr-x 1 root root 695496 jun 7 2008 libgstreamer-0.10.so.0.16.0
    lrwxrwxrwx 1 root root 25 dic 9 17:19 libgstriff-0.10.so.0 -> libgstriff-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 42980 jun 7 2008 libgstriff-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 24 dic 9 17:19 libgstrtp-0.10.so.0 -> libgstrtp-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 68580 jun 7 2008 libgstrtp-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 25 dic 9 17:19 libgstrtsp-0.10.so.0 -> libgstrtsp-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 56236 jun 7 2008 libgstrtsp-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 24 dic 9 17:19 libgstsdp-0.10.so.0 -> libgstsdp-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 26572 jun 7 2008 libgstsdp-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 24 dic 9 17:19 libgsttag-0.10.so.0 -> libgsttag-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 56000 jun 7 2008 libgsttag-0.10.so.0.13.0
    lrwxrwxrwx 1 root root 21 dic 10 15:15 libgstvideo-0.10.so -> libgstvideo-0.10.so.0
    lrwxrwxrwx 1 root root 26 dic 9 17:19 libgstvideo-0.10.so.0 -> libgstvideo-0.10.so.0.13.0
    -rwxr-xr-x 1 root root 18456 jun 7 2008 libgstvideo-0.10.so.0.13.0
    So, I understand that gstream libraries are installed.

  10. #9
    Join Date
    Aug 2008
    Location
    Ukraine, Krivoy Rog
    Posts
    1,963
    Thanked 370 Times in 336 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    try to specify this dir in LD_LIBRARY_PATH and then build phonon.
    Qt Assistant -- rocks!
    please, use tags [CODE] & [/CODE].

  11. #10
    Join Date
    May 2008
    Location
    Spain
    Posts
    90
    Thanks
    13
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Install Qt 4.5 with phonon support

    Hello,

    my environment variables:

    export QTDIR=/opt/Qt
    export LD_LIBRARY_PATH=$QTDIR/lib:/usr/lib:/lib
    export POINTERCAL_FILE=/mnt/hdd1/touch_conf/pointercal
    export QWS_MOUSE_PROTO=tslib:/dev/input/event0
    export QWS_DISPLAY="VNC:LinuxFb"
    But same error. I will check instalation again.

Similar Threads

  1. How to install phonon on qtx11-4.5.2 in linux..?
    By balajir in forum Installation and Deployment
    Replies: 28
    Last Post: 11th February 2010, 11:14
  2. Qt/X11 source-distro apps corrupting KDE Desktop background
    By wdezell in forum Installation and Deployment
    Replies: 5
    Last Post: 23rd July 2009, 21:10
  3. Problem with compiling qt on windows xp with phonon
    By junky in forum Installation and Deployment
    Replies: 3
    Last Post: 13th April 2009, 08:13
  4. Qt-4.4.0 installation error in linux
    By babu198649 in forum Installation and Deployment
    Replies: 4
    Last Post: 27th May 2008, 14:35
  5. Access to PostgreSQL DB on a linux server
    By rmagro in forum Qt Programming
    Replies: 28
    Last Post: 13th March 2008, 09:02

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.