Results 1 to 5 of 5

Thread: QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

  1. #1
    Join Date
    Mar 2010
    Posts
    68
    Thanks
    8
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows Symbian S60

    Default QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

    Few days ago, I create a GUI application by QT creator and use debugger without problems. I have changed the widget name, and add some controls into (I haven't add any codes to this project).

    Today, I return this project, set a breakpoint at the main function and try to use debugger, but the debugger doesn't stop at the breakpoint, when I close my application (run by debugger), I got a message as following:

    "The inferior stopped because it received a signal from the Operating System.
    -- Signal Name: SIGSEG -- Segment Fault."

    But, I click the Run button, my application run without errors (no warnings)
    I try to create a new project, the debugger works fine.

    I'm using Windows 7 Ultimate Licensed (fresh, no virus), QT Creator 1.3.1, QT Frameworks 4.6.2

    stranger, help me!

  2. #2
    Join Date
    May 2008
    Posts
    155
    Thanked 15 Times in 13 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

    The segmentation fault means your program crashed.
    If a breakpoint is not hit you might not be running a debug build.

  3. #3
    Join Date
    Mar 2010
    Posts
    68
    Thanks
    8
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows Symbian S60

    Default Re: QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

    I got it! I changed the build config, it works fine now!

  4. #4
    Join Date
    Nov 2011
    Posts
    1
    Qt products
    Qt3 Qt4 Qt/Embedded Qt Jambi PyQt3 PyQt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

    Quote Originally Posted by Kevin Hoang View Post
    I got it! I changed the build config, it works fine now!
    Hi Kevin,
    I run into the same issue, could you please kindly share how you solve it?

    Thanks a lot!

  5. #5
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,543
    Thanks
    13
    Thanked 1,577 Times in 1,506 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: QT creator Debugger doesn't stop at breakpoint and show up "Segmentation Fault"

    1 year, 7 months, and 14 days ago Kevin decided that in order to debug a program you need to have a debug, not release, build.

    BTW: It is poor netiquette to resurrect threads that have been long dormant.

Similar Threads

  1. linux "Segmentation fault"
    By harrison in forum Newbie
    Replies: 5
    Last Post: 3rd March 2010, 09:33
  2. "Segmentation Fault" for QHttp::setHost()
    By pritam in forum Newbie
    Replies: 2
    Last Post: 3rd March 2010, 07:18
  3. why is there so strange "Segmentation fault" ?
    By lanmanck in forum Qt Programming
    Replies: 9
    Last Post: 2nd March 2010, 12:55
  4. why qstringlist *ps "Segmentation fault"?
    By lanmanck in forum Qt Programming
    Replies: 6
    Last Post: 23rd September 2009, 07:46
  5. QModelIndex destructor causes "user breakpoint"
    By Arthur in forum Qt Programming
    Replies: 2
    Last Post: 30th March 2006, 09:11

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.