Results 1 to 1 of 1

Thread: windows 7 + mingw + qt 4.x + qca 2.x + openssl 0.98

  1. #1
    Join Date
    May 2010
    Qt products

    Default windows 7 + mingw + qt 4.x + qca 2.x + openssl 0.98

    I really need your help.
    I have a windows 7 (32 bit) system and use qt 4.6.2 with eclipse CDT Release 3.5.2 and MinGW 5.1.6.

    Now I want to add the QCA crypto libs.
    For that I downloaded:
    - vcredist_x86.exe
    - Win32OpenSSL-0_9_8n.exe
    - qca-ossl-2.0.0-beta3.tar.bz2

    First I installed the Visual C++ 2008 Redistributable Package (vcredist_x86.exe) to install OpenSSL.
    Second I installed OpenSSL to C:\OpenSSL.
    Third I unpacked the to C:\qca-2.0.1-mingw. Then I fixed the from this:
    LINKAGE = -lqca
    CONFIG(debug, debug|release) {
    windows:LINKAGE = -lqcad
    mac:LINKAGE = -lqca_debug

    to this:
    LINKAGE = -lqca2
    CONFIG(debug, debug|release) {
    windows:LINKAGE = -lqcad2
    mac:LINKAGE = -lqca_debug
    because the new qca libs called qca2 and not qca.
    After that I ran the installwin.bat.

    Fourth I unpacked the qca-ossl-2.0.0-beta3.tar.bz2 to C:\qca-ossl-2.0.0-beta3.
    I fixed the qca-ossl.cpp file by adding the line:
    #undef OBJ_whirpool
    Then I ran the configwin.bat like this: configwin rd
    After that I ran qmake and then make.
    At the end I added the directory crypto to the plugins folder of my QT path (C:\Qt\4.6.2\plugins\crypto) and copied the qca-ossl2.dll and qca-ossld2.dll from the qca-ossl-2.0.0-beta3\lib folder to the plugin\crypto folder.

    Everything worked with here. But now I want to use the QCA - libs in my application.
    I wrote a little helloWorld Gui like this:

    Qt Code:
    1. #include "helloworldtestqt.h"
    2. #include <QtGui>
    3. #include <QApplication>
    4. #include <QtCrypto>
    6. int main(int argc, char *argv[])
    7. {
    8. QApplication a(argc, argv);
    9. HelloWorldTestQt w;
    11. return a.exec();
    12. }
    To copy to clipboard, switch view to plain text mode 

    and created the following pro file:
    TEMPLATE = app
    TARGET = HelloWorldTestQt
    QT += core gui
    HEADERS += helloworldtestqt.h
    SOURCES += main.cpp \
    FORMS += helloworldtestqt.ui

    CONFIG += crypto

    but when I compile my application now with eclipse I get the following output (see attachment for more details):
    ../../Qt/qca-2.0.1-mingw/include/QtCrypto/qca_core.h:882: note: QCA::Provider::Context::Context(QCA::Provider*, const QString&)
    mingw32-make[1]: *** [debug/main.o] Error 1
    mingw32-make[1]: Leaving directory `C:/workspace/HelloWorldTestQt'
    mingw32-make: *** [debug] Error 2

    What did I wrong? Did I forget anything (setting pahtes, variables, ....)?

    Thank you for your help.

    Attached Files Attached Files

Similar Threads

  1. Compiling static for Windows with OpenSSL
    By manekineko in forum Qt Programming
    Replies: 19
    Last Post: 23rd March 2012, 23:13
  2. How to Building Qt with OpenSSL support using the Windows SDK
    By josecarlosmissias in forum Qt Programming
    Replies: 2
    Last Post: 18th October 2011, 07:48
  3. Replies: 0
    Last Post: 31st May 2010, 16:10
  4. Qt 4.5.3 openssl 0.9.8k windows static mingw32
    By tpf80 in forum Installation and Deployment
    Replies: 3
    Last Post: 26th February 2010, 06:44
  5. Qt for Windows CE with OpenSSL support
    By Jonas in forum Installation and Deployment
    Replies: 2
    Last Post: 4th February 2010, 08:36

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.