Results 1 to 5 of 5

Thread: Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

  1. #1
    Join Date
    Jan 2009
    Posts
    47
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    Windows

    Default Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

    Hello,

    I have problems compiling QtWebkit for 64-bit windows. See errors below. Thanks.

    Creating library ..\..\..\..\lib\QtWebKitd4.lib and object ..\..\..\..\lib\Qt
    WebKitd4.exp
    PluginViewWin.obj : error LNK2019: unresolved external symbol _HBeginPaint refer
    enced in function "private: static struct HDC__ * __cdecl WebCore::PluginView::h
    ookedBeginPaint(struct HWND__ *,struct tagPAINTSTRUCT *)" (?hookedBeginPaint@Plu
    ginView@WebCore@@CAPEAUHDC__@@PEAUHWND__@@PEAUtagP AINTSTRUCT@@@Z)
    PluginViewWin.obj : error LNK2019: unresolved external symbol _HEndPaint referen
    ced in function "private: static int __cdecl WebCore::PluginView::hookedEndPaint
    (struct HWND__ *,struct tagPAINTSTRUCT const *)" (?hookedEndPaint@PluginView@Web
    Core@@CAHPEAUHWND__@@PEBUtagPAINTSTRUCT@@@Z)
    ..\..\..\..\lib\QtWebKitd4.dll : fatal error LNK1120: 2 unresolved externals
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0\
    VC\BIN\x86_amd64\link.EXE"' : return code '0x460'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0\
    VC\BIN\nmake.exe"' : return code '0x2'

  2. #2
    Join Date
    Apr 2010
    Location
    Switzerland
    Posts
    16
    Thanks
    3
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

    are there any other Qt versions installed on your machine?

  3. #3
    Join Date
    Jan 2009
    Posts
    47
    Thanks
    6
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

    Yes, there are 3 other Qt on my machines, Qt 4.7 beta for 32-bit Windows + Qt 4.4.3 for both 32-bit and 64-bit windows

  4. #4
    Join Date
    Nov 2010
    Posts
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

    I have the same problem, only the Qt Version is different (4.6.1).
    I followed the instructions given on this side:
    http://trac.webkit.org/wiki/BuildingQtOnWindows

    Do someone have a hint for me?

  5. #5

    Default Re: Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008

    Hello there,

    I have to solve the problems you mentioned here today and found solution. Here is more than one bug in Webkit.pro and QMake which cause compilation errors.

    First problem is in Webkit.pro file where is wrongly used variable QMAKE_HOST.arch instead of QMAKE_TARGET.arch, second problem for me was missing support for VS2010, so I have to update one IF statement in the Webkit.pro. And last problem was in QMake in test if we want to compile 32 or 64 bit version. This decision is made by PATH settings which is tested against incorrectly created string with two \\ chars instead of one \.

    More detailed description how to solve all these problems is available on my blog here: http://blog.inventic.eu/2011/01/prob...indows-64-bit/

    During my work with Qt I found more than this bugs and I'm interested if there is any step-by-step manual how can I contribute this fixes to Qt source codes. I never contribute to any open-source project, so this is new for me ;-). Thanks.

    Ludek

    PS: Sorry for my english ;-)

Similar Threads

  1. Building Qt 4.6 on Windows (msvs 2008)
    By Iskander in forum Installation and Deployment
    Replies: 13
    Last Post: 27th August 2009, 13:19
  2. Building a sqldriver (QIBASE) in windows msvc++2008
    By ProTonS in forum Installation and Deployment
    Replies: 1
    Last Post: 16th July 2009, 16:39
  3. QTWebKit unable to load download link
    By myrky in forum Qt Programming
    Replies: 4
    Last Post: 9th July 2009, 07:09
  4. Deploying on Windows problems with QtWebKit
    By josepvr in forum Installation and Deployment
    Replies: 3
    Last Post: 8th October 2008, 12:00
  5. QT 4.3 beta on Windows 2000
    By Nyphel in forum Installation and Deployment
    Replies: 3
    Last Post: 4th April 2007, 19:54

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.