Results 1 to 3 of 3

Thread: Qt 4.7: why is QtHelpd4.dll required?! (Windows deployment)

  1. #1
    Join Date
    Mar 2010
    Posts
    319
    Thanks
    1
    Thanked 14 Times in 12 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Question Qt 4.7: why is QtHelpd4.dll required?! (Windows deployment)

    Hi, I am using CMake to build and pack (with CPack) my Qt application. I am currently looking into updating my packing procedure for Windows. Now, my application uses QtHelp, so I clearly need to deploy it (as confirmed by Dependency Walker). However, though I am building a release version of my application, QtHelpd4.dll is required (and, as a result, also the debug version of a few other Qt libraries) while a release version of the other Qt libraries is required. Incidentally, this results in QtCore4.dll and QtCored4.dll being both required (the second one as a result of QtHelpd4.dll being required).

    Now, what I am wondering is why on earth is the debug version of QtHelp required when the release version of everything else is needed?

    Cheers, Alan.

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,013 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qt 4.7: why is QtHelpd4.dll required?! (Windows deployment)

    Dependency walker should show you what depends on the debug dll. It's probably not really your main application as release and debug versions of Qt can't be used in the same executable due to name clashes.
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3
    Join Date
    Mar 2010
    Posts
    319
    Thanks
    1
    Thanked 14 Times in 12 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qt 4.7: why is QtHelpd4.dll required?! (Windows deployment)

    Ok, now, this is very weird! I have just built my project at home and Dependency Walker tells me that it depends on QtHelp4.dll and not QtHelpd4.dll as at work, and indeed the package I build works fine on a clean Windows virtual machine while that of work doesn't work unless I deploy some debug DLLs (incidentally, whether it should be done or not, release and debug DLLs live well together). Anyway, I guess I will have to investigate what's going on with my work computer...


    Added after 1 28 minutes:


    Interestingly enough, I have just compared the Qt / Qt Creator directory of my computer at work against the one I have at home, and some files have a different size and timestamp, even though they are both the 2010.05 version. Hmm... me thinks that I might want to reinstall my work copy of Qt / Qt Creator on Monday...
    Last edited by agarny; 8th January 2011 at 02:55.

Similar Threads

  1. Windows 7 Deployment
    By mlheese in forum Installation and Deployment
    Replies: 0
    Last Post: 10th November 2010, 22:21
  2. Deployment problem on qt 4.5 windows
    By brasio in forum Installation and Deployment
    Replies: 14
    Last Post: 26th June 2010, 01:05
  3. Windows SDK setup fails (required for phonon)
    By pospiech in forum Installation and Deployment
    Replies: 14
    Last Post: 28th January 2010, 14:37
  4. Deployment Procedure On Windows On Linux and Windows
    By Harshith J.V. in forum Installation and Deployment
    Replies: 4
    Last Post: 9th July 2009, 12:27
  5. deployment of Qt 4.3.4 exe on Windows?
    By vishal.chauhan in forum Installation and Deployment
    Replies: 5
    Last Post: 1st April 2008, 13:30

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.