Results 1 to 4 of 4

Thread: Qt 4.4.3 build error

  1. #1
    Join Date
    Sep 2010
    Posts
    5
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Exclamation Qt 4.4.3 build error

    Hi,

    I am building Qt4.4.3 on Solaris 10.I am able to configure perfectly.
    Please find my command below

    ./configure -prefix /apps/qt-all-commercial-src-4.4.3_ssl -platform solaris-cc -static -no-fontconfig -no-webkit -no-phonon -openssl-linked -I/home/tcssrpa/ssl/include -L/home/tcssrpa/ssl/lib

    i configured with openssl linked support

    After i give gmake (after 15 mins) it kicks the following error.


    Error:
    CC -mt -R/apps/Qt/qt-x11-commercial-src-4.4.3_ssl/lib -R/apps/Qt/qt-x11-commercial-src-4.4.3_ssl/lib -o ../../../bin/uic3 .obj/release-static/customwidgetsinfo.o .obj/release-static/databaseinfo.o .obj/release-static/driver.o .obj/release-static/treewalker.o .obj/release-static/ui4.o .obj/release-static/uic.o .obj/release-static/validator.o .obj/release-static/cppextractimages.o .obj/release-static/cppwritedeclaration.o .obj/release-static/cppwriteicondata.o .obj/release-static/cppwriteicondeclaration.o .obj/release-static/cppwriteiconinitialization.o .obj/release-static/cppwriteincludes.o .obj/release-static/cppwriteinitialization.o .obj/release-static/main.o .obj/release-static/ui3reader.o .obj/release-static/parser.o .obj/release-static/domtool.o .obj/release-static/object.o .obj/release-static/subclassing.o .obj/release-static/form.o .obj/release-static/converter.o .obj/release-static/widgetinfo.o .obj/release-static/embed.o .obj/release-static/qt3to4.o .obj/release-static/deps.o -L/home/tcssrpa/ssl/lib -L/apps/Qt/qt-x11-commercial-src-4.4.3_ssl/lib -L/usr/sfw/lib -lQt3Support -L/home/tcssrpa/ssl/lib -L/apps/Qt/qt-x11-commercial-src-4.4.3_ssl/lib -L/usr/sfw/lib -lQtSql -L/usr/openwin/lib -lQtNetwork -lxnet -lssl -lcrypto -lQtXml -lQtGui -lpng -lfreetype -lSM -lICE -lXi -lXrender -lXext -lX11 -lresolv -lsocket -lnsl -lQtCore -lz -lm -ldl -lpthread -lrt
    Undefined first referenced
    symbol in file
    QIconvCodec::QIconvCodec() /apps/Qt/qt-x11-commercial-src-4.4.3_ssl/lib/libQtCore.a(qtextcodec.o)
    ld: fatal: Symbol referencing errors. No output written to ../../../bin/uic3
    make: *** [../../../bin/uic3] Error 1

    i am using compiler CC 5.8

    Please help me on this ...its urgent!!!!

  2. #2
    Join Date
    Apr 2010
    Posts
    769
    Thanks
    1
    Thanked 94 Times in 86 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11

    Default Re: Qt 4.4.3 build error

    Try adding '--no-iconv' to your configure call. If that fails (some versions of Qt force the dependency, even when it is explicitly turned off) you'll have to obtain and install the iconv package for your Solaris environment.

    Note that Solaris has been very poorly supported by Qt for quite a while.

  3. #3
    Join Date
    Feb 2012
    Posts
    6
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Qt 4.4.3 build error

    hi,how about the condition of QT installtion on Solaris?can you tell me how to install QT in solaris.my name is marcus .can you add me msn:minshengbai@live.cn (or qq if you have .375308292)or reply my message at this website.?thank you

  4. #4
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,734
    Thanks
    13
    Thanked 1,610 Times in 1,537 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: Qt 4.4.3 build error

    Solaris is an unsupported environment (see supported platforms) so, although it should be possible, YMMV. You can attempt to install Qt on Solaris by following exactly the same set of documented commands as any other UNIX/X11 user. The dependencies are also documented.

Similar Threads

  1. Build release and run error
    By gabriele in forum Newbie
    Replies: 11
    Last Post: 16th February 2010, 22:23
  2. Qwt build error with Qt 4.6.0-tp1
    By alex-krutikov in forum Qwt
    Replies: 6
    Last Post: 20th December 2009, 10:43
  3. qt build error
    By sunnyan in forum Qt for Embedded and Mobile
    Replies: 1
    Last Post: 30th November 2009, 09:25
  4. Error to build Qt4.4 on Mac OS X 10.5.3
    By chackal_sjc in forum Installation and Deployment
    Replies: 8
    Last Post: 20th July 2008, 20:38
  5. QVistaHelper build error
    By jhearon in forum Installation and Deployment
    Replies: 2
    Last Post: 30th September 2007, 09:05

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.