Results 1 to 2 of 2

Thread: Qtwebkit performance issue ???????

  1. #1
    Join Date
    Jun 2010
    Posts
    102
    Thanks
    3
    Qt products
    Qt4 Qt/Embedded Qt Jambi PyQt3 PyQt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Qtwebkit performance issue ???????

    I am facing some terrible performance problem with Qt webkit based
    application on our board. Indeed I build Qt Demo Browser application for
    my board and it has
    terrible terrible slow performance. It is highly un responsive, when
    scroll using mouse it scrolls very little after almost two min, when I
    click on any link
    it opens that link after a minute, When I go to some site like
    http://cnn.com and do little browsing it crashes. I am running with
    directfb support.

    i have tested other web kit based small browser sort of application and that works good.
    To me it looks like some issue with Qt porting of webkit or in Demo browser
    but I have no clue what is causing this problem.

    Can any one please point me what should I look for to solve this problem?
    any hint will be highly appreciated.
    Contact: Skype: sonnh89
    Yahoo: nhs_0702@yahoo.com

    Liên hệ SKype: sonnh89

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,363
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qtwebkit performance issue ???????

    Aren't you running out of resources? Maybe you need to remove some of the features while compiling Qt or QtWebKit?
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


Similar Threads

  1. Qt 4.7 beta 2 - QtWebkit link issue 64-bit Windows & VS 2008
    By ttvo in forum Installation and Deployment
    Replies: 4
    Last Post: 21st October 2011, 14:23
  2. Replies: 0
    Last Post: 5th October 2010, 13:36
  3. The performance of QtWebKit on Wince 6.0, including MIPS platform
    By favor in forum Qt for Embedded and Mobile
    Replies: 4
    Last Post: 22nd April 2010, 08:57
  4. QtWebKit and flash performance issues
    By caelestis in forum Qt Programming
    Replies: 0
    Last Post: 7th February 2010, 05:08
  5. Performance Issue
    By linuxdev in forum Qt Programming
    Replies: 1
    Last Post: 10th December 2008, 15:00

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.