Results 1 to 5 of 5

Thread: Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

  1. #1
    Join Date
    Oct 2011
    Posts
    19
    Thanks
    2
    Qt products
    Qt3
    Platforms
    Unix/X11

    Default Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

    Hello,

    I am trying to install QWT 5.2.2 on Qt 3 but I get the following error. Can anyone help me? I already have Qwt 0.4.1(4.1) installed , was trying to install this over it.

    This is what I get.

    Qt Code:
    1. [root@localhost qwt-5.2.2]# make
    2. cd src && make -f Makefile
    3. make[1]: Entering directory `/root/Qt/Babysteps-Examples-Qt/qwt-5.2.2/src'
    4. g++ -c -pipe -Wall -W -O2 -march=i386 -mcpu=i686 -g -DGLX_GLXEXT_LEGACY -fno-use-cxa-atexit -fno-exceptions -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.1/mkspecs/default -I. -I/usr/lib/qt-3.1/include -Imoc/ -o obj/qwt_abstract_scale_draw.o qwt_abstract_scale_draw.cpp
    5. qwt_abstract_scale_draw.cpp:15:21: qlocale.h: No such file or directory
    6. qwt_abstract_scale_draw.cpp: In member function `virtual QwtText
    7. QwtAbstractScaleDraw::label(double) const':
    8. qwt_abstract_scale_draw.cpp:362: `QLocale' undeclared (first use this function)
    9. qwt_abstract_scale_draw.cpp:362: (Each undeclared identifier is reported only
    10. once for each function it appears in.)
    11. qwt_abstract_scale_draw.cpp:362: parse error before `::' token
    12. qwt_abstract_scale_draw.cpp:361: warning: unused parameter `double value'
    13. make[1]: *** [obj/qwt_abstract_scale_draw.o] Error 1
    14. make[1]: Leaving directory `/root/Qt/Babysteps-Examples-Qt/qwt-5.2.2/src'
    15. make: *** [sub-src] Error 2
    16. [root@localhost qwt-5.2.2]#
    To copy to clipboard, switch view to plain text mode 

  2. #2
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,253
    Thanked 860 Times in 809 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

    Qt 5.2.x needs Qt 3.3.x.

    Uwe

  3. #3
    Join Date
    Oct 2011
    Posts
    19
    Thanks
    2
    Qt products
    Qt3
    Platforms
    Unix/X11

    Default Re: Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

    So which version is the latest which will work properly on Qt 3 ( or Qt 3.1)?

    I am trying to find about the differnt version supporting compatibility but its little hard to search about the previous versions of Qwt.


    Added after 1 38 minutes:


    Ok I had to look into documentation of all the version and I have found this :

    Till Qwt 5.0.1 -> Qt 3.x and Qt 4.x+ is supportted
    Qwt 5.0.2 - Qwt 5.2.2 > Qt 3.3.x and later.
    And finally
    Qwt 6 -> Only Qt 4.4 + ( Qt 3 support fully dropped.)

    This is as far as I remember after going through all the documentations. Uwe or anyone, please add to it if anything is incorrect or incomplete about it. So that its help to other people. Thanks.


    Added after 15 minutes:


    Ok what went wrong now?
    Qt Code:
    1. g++ -c -pipe -Wall -W -O2 -march=i386 -mcpu=i686 -g -DGLX_GLXEXT_LEGACY -fno-use-cxa-atexit -fno-exceptions -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.1/mkspecs/default -I. -I/usr/lib/qt-3.1/include -Imoc/ -o obj/qwt_paint_buffer.o qwt_paint_buffer.cpp
    2. qwt_paint_buffer.cpp: In member function `void
    3. QwtPaintBuffer::open(QPaintDevice*, const QRect&, QPainter*)':
    4. qwt_paint_buffer.cpp:144: `WNoAutoErase' is not a member of type `Qt'
    5. make[1]: *** [obj/qwt_paint_buffer.o] Error 1
    6. make[1]: Leaving directory `/root/Qt/Babysteps-Examples-Qt/Last working Qwt/qwt-5.0.1/src'
    7. make: *** [sub-src] Error 2
    To copy to clipboard, switch view to plain text mode 
    Trying the next lower version.
    Last edited by amitahire; 25th October 2011 at 08:19.

  4. #4
    Join Date
    Oct 2011
    Posts
    19
    Thanks
    2
    Qt products
    Qt3
    Platforms
    Unix/X11

    Default Re: Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

    You know what? I get the same error with Qwt 5.0.0

    Why isn't the QPaintBuffer class compling? Anyway help me with it. I am using Qwt 0.4.1 now, I thought maybe I will upgrade the thinga I can. (Using Qt 3-1 and Red Hat 9 - Cant change)

  5. #5
    Join Date
    Oct 2011
    Posts
    19
    Thanks
    2
    Qt products
    Qt3
    Platforms
    Unix/X11

    Default Re: Installing Qwt 5.2.2 on Red Hat 9 + Qt 3.1

    Ok finally managed to compile qwt 5.0.1 (have to test) but tell me one thing, its not possible to compile plugin in Qt 3.1?

    Where are these header files???

    Qt Code:
    1. #include <QtPlugin>
    2. #include <QDesignerFormEditorInterface>
    3. #include <QDesignerFormWindowInterface>
    4. #include <QDesignerFormWindowCursorInterface>
    5. #include <QExtensionManager>
    6. #include <QErrorMessage>
    To copy to clipboard, switch view to plain text mode 

    So I am guessing that Qwt plugin for Qt 3.1 is not available??

Similar Threads

  1. Need help installing Qwt
    By Computer Hater in forum Qwt
    Replies: 35
    Last Post: 10th October 2011, 19:57
  2. Installing Qt
    By Aman607 in forum Newbie
    Replies: 3
    Last Post: 18th July 2011, 00:39
  3. Installing Qwt 5.1.1
    By WXNSNW in forum Qwt
    Replies: 3
    Last Post: 18th September 2008, 15:06
  4. Installing Qt 4 on Mac os X
    By qtray in forum Installation and Deployment
    Replies: 1
    Last Post: 8th August 2008, 22:34
  5. Installing
    By bsws1079 in forum Newbie
    Replies: 3
    Last Post: 3rd April 2007, 00:19

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.