Results 1 to 1 of 1

Thread: phonon for imx53 doesn't work properly

  1. #1

    Default Re: phonon for imx53 doesn't work properly

    Hi guys,

    I am trying to implement Phonon for imx53. gst-launch works fine on my platform, but no sound from phonon. My default setting in asound.conf is
    pcm.!default {
    type hw
    card 0
    device 0
    subdevice 3
    pcm.!default {
    type plug
    slave {
    pcm "hw:0,0,3"
    both ok. I checked /proc/asound and i found two cards :card0 is imxesai and card1 is imx3stack. i tried like "gst-launch playbin2 uri=file:///dir/k.wav" and it works fine.
    I used Phonon::BackendCapabilities::availableAudioOutputD evices() and found out i have four devices available:
    i can't see subdevices in phonon but i set defaults.pcm.subdevice to 3 in asla.conf.

    i also tried audioOutput->setOutputDevice( and other devices but still no luck.

    Now i don't know what to do next...
    Plus, i start imx53 using nfs on ubuntu, does that matter?

    Added after 14 minutes:

    I also wanna know how phonon get available device list? it seems that it doesn't get asound default setting.
    some more information abount my platform:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: imxesai [imxesai], device 0: imxesai PCM [imxesai PCM]
    Subdevices: 4/4
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    card 1: imx3stack [imx-3stack], device 0: Voice SSI-0 []
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: imx3stack [imx-3stack], device 1: Bluetooth SSI-1 []
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    No error message during playing, but no sound...
    here is message from phonon:
    ASFPARSER_00.02.09 build on Jun 22 2010 09:10:09.
    MFW_GST_ASF_PLUGIN 1.9.0 build on Feb 3 2011 12:16:46.
    WMA10D_03.03.00_CORTEX-A8 build on Jul 22 2010 18:06:11.
    MFW_GST_WMA10DEC_PLUGIN 1.9.0 build on Feb 3 2011 12:16:30.

    Last edited by yinyin; 2nd December 2011 at 07:26.

Similar Threads

  1. Replies: 2
    Last Post: 2nd August 2011, 16:05
  2. Graphics scene doesn't repaint properly
    By blooglet in forum Qt Programming
    Replies: 5
    Last Post: 16th April 2011, 16:48
  3. My showevent does not work properly.
    By tonnot in forum Newbie
    Replies: 7
    Last Post: 18th February 2011, 08:18
  4. QProgressBar "crash" - doesn't work properly
    By metRo_ in forum Qt Programming
    Replies: 6
    Last Post: 23rd October 2010, 14:56
  5. Delegate doesn't paint properly
    By woodtluk in forum Qt Programming
    Replies: 4
    Last Post: 11th August 2010, 12:43


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.