Results 1 to 2 of 2

Thread: How to install Qt ARM version with phonon support?

  1. #1
    Join Date
    Jul 2012
    Posts
    1
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default How to install Qt ARM version with phonon support?

    Hello,
    I have qt-everywhere-opensource-src-4.8.1 and I would like to configure it into ARM version with phonon support:
    (./configure -prefix /opt/qtLib -release -opensource -shared -embedded arm -xplatform qws/linux-arm-g++ -no-fast -no-largefile -qt-sql-sqlite -no-qt3support -multimedia -audio-backend -phonon -phonon-backend -no-svg -webkit -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -nomake examples -nomake demos -nomake docs -make tools -v -silent -no-cups -no-separate-debug-info -glib -I /usr/include/glib-2.0 -L /usr/lib/glib-2.0 -qt-mouse-tslib -I /opt/tsLib/include -L /opt/tsLib/lib -I /usr/include -L /usr/lib -force-pkg-config)

    The error:
    Glib auto-detection... ()
    compiling glib.cpp
    glib.cpp: In function 'int main(int, char**)':
    glib.cpp:55: warning: 'pollfd' is used uninitialized in this function
    linking glib
    /tools/arm-linux-gcc/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.3/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible /usr/lib/libgthread-2.0.so when searching for -lgthread-2.0
    /tools/arm-linux-gcc/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.3/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible /usr/lib/libgthread-2.0.a when searching for -lgthread-2.0
    /tools/arm-linux-gcc/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.3/../../../../arm-none-linux-gnueabi/bin/ld: cannot find -lgthread-2.0
    collect2: ld returned 1 exit status
    make: *** [glib] 错误 1
    Glib disabled.
    Glib support cannot be enabled due to functionality tests!
    Turn on verbose messaging (-v) to ./configure to see the final report.
    If you believe this message is in error you may use the continue
    switch (-continue) to ./configure to continue.
    If I remove option -phonon -phonon-backend -glib, I can configure and compile Qt 4.8.1 without problems.

    Any ideas?
    Best regards.

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,014 Times in 4,792 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: How to install Qt ARM version with phonon support?

    It seems your environment can't find a compatible glib implementation. Do you have it built for your device?
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


Similar Threads

  1. Install Qt 4.5 with phonon support
    By webquinty in forum Installation and Deployment
    Replies: 9
    Last Post: 11th December 2009, 21:48
  2. how to install LGPL version of Qt?
    By rajesh in forum Installation and Deployment
    Replies: 11
    Last Post: 22nd May 2009, 10:15
  3. European Language support in Qt 3.3 version
    By gary_qt in forum Newbie
    Replies: 4
    Last Post: 22nd August 2008, 11:48
  4. how can i install the Qt ziped version?
    By coder1985 in forum Installation and Deployment
    Replies: 1
    Last Post: 19th November 2007, 10:59
  5. how to install kde new version on redhat 9
    By amit_pansuria in forum KDE Forum
    Replies: 3
    Last Post: 22nd November 2006, 15:36

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.