Results 1 to 6 of 6

Thread: Deploying Qt 4.8.4 application on Mac OS X 10.6

  1. #1
    Join Date
    Feb 2011
    Posts
    354
    Thanks
    17
    Thanked 26 Times in 23 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Windows

    Default Deploying Qt 4.8.4 application on Mac OS X 10.6

    I am trying to deploy my application written in C++/Qt 4.8.4 on Mac OS X. I would like it to run on Mac OS X 10.6 and higher. In order to do that I set Xcode deployment target to 10.6, also I use macdeployqt. It works fine on Mac OS X 10.8, but on 10.6 there are lots and lots of issues.

    The application crashes because of missing frameworks which are located in different places on 10.6 and 10.8:

    Dyld Error Message:
    Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
    Referenced from: /Volumes/deploy/MyApp.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui

    Library not loaded: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
    Referenced from: /Applications/MyApp.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui

    ...Similar QtWebKit, QtNetwork issues
    etc etc...
    And there are trickier issues are about missing symbols in some system libraries, like libobjc.A.dylib, libSystem.B.dylib, libc++abi.dylib, libc++.1.dylib etc:
    Dyld Error Message:
    Symbol not found: __dispatch_queue_attr_concurrent
    Referenced from: /tmp/MyApp.app/Contents/MacOS/../Frameworks/libobjc.A.dylib
    Expected in: /usr/lib/libSystem.B.dylib
    in /tmp/MyApp.app/Contents/MacOS/../Frameworks/libobjc.A.dylib
    Could somebody explain how to fix this? I have tried to set QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.6 in the .pro file, I am using macdeployqt just passing MyApp.app as the only argument. I have already spent a week dealing with all that errors, so any help would be very appreciated.

  2. #2
    Join Date
    Feb 2011
    Posts
    354
    Thanks
    17
    Thanked 26 Times in 23 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Windows

    Default Re: Deploying Qt 4.8.4 application on Mac OS X 10.6

    Ok, I see this question is not going to be answered, so I'll ask something different. Is it possible to target Qt 4.8.4 application to Mac OS X 10.6 or this version of Qt is not fully compatible with Snow Leopard?

  3. #3
    Join Date
    Feb 2013
    Posts
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Deploying Qt 4.8.4 application on Mac OS X 10.6

    I use Qt 4.8.4 on Mac OS X without significant problems.
    Using Mac OS X SDK 10.6 and setting QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.5 makes it run on any Intel system from 10.5 to 10.8.

    However, I use Mac OS X 10.7 and GCC (not CLang) for development.

    Please also check that you have qt.conf file inside your bundle.

  4. #4
    Join Date
    Feb 2011
    Posts
    354
    Thanks
    17
    Thanked 26 Times in 23 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Windows

    Default Re: Deploying Qt 4.8.4 application on Mac OS X 10.6

    yes, it works fine (tested on 10.6 - 10.8) if you develop on 10.7, but developing on 10.8 makes it impossible to run on 10.6 or 10.7 regardless of xcode deployment target or QMAKE_MACOSX_DEPLOYMENT_TARGET

  5. #5
    Join Date
    Feb 2011
    Location
    Romania
    Posts
    53
    Thanks
    1
    Thanked 11 Times in 9 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Deploying Qt 4.8.4 application on Mac OS X 10.6

    Hi, I'm not sure about qmake QMAKE_MACOSX_DEPLOYMENT_TARGET, but I'm sure if application is developed in XCode on Mac 10.8 and target is set to 10.6, app will run just fine in Snow Leoprad. I'm not use macdeploy but manually set dependecies path for alls dylibs

  6. #6
    Join Date
    Feb 2011
    Posts
    354
    Thanks
    17
    Thanked 26 Times in 23 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Windows

    Default Re: Deploying Qt 4.8.4 application on Mac OS X 10.6

    Yes, I am developing with Xcode 4.5.2 on OSX 10.8 setting deployment target to 10.6. The deployed version works only on 10.8, but if I do the same on 10.7, it works fine on 10.6-10.8.

    I believe it depends on what kind of functionality you are using in the project. Perhaps, your project doesn't need CoreText.framework or ImageIO.framework. My hardest issue is about missing symbols in system libraries, that doesn't seem to be actually related to macdeployqt as long as it sets only library paths.

Similar Threads

  1. Deploying an application on a different PC
    By adyb in forum Installation and Deployment
    Replies: 2
    Last Post: 25th July 2011, 15:53
  2. Deploying qt application under mac osx
    By lechoo in forum Installation and Deployment
    Replies: 0
    Last Post: 24th September 2010, 16:56
  3. deploying my qt application
    By arunredi in forum Installation and Deployment
    Replies: 1
    Last Post: 22nd May 2008, 12:34
  4. Deploying Qt application on Mac OS X
    By mourad in forum Installation and Deployment
    Replies: 1
    Last Post: 30th March 2008, 17:19
  5. Deploying Qt Application on Mac?
    By vishal.chauhan in forum Installation and Deployment
    Replies: 2
    Last Post: 30th March 2007, 10:40

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.