Results 1 to 3 of 3

Thread: Requirements / dependencies for Qt4 Designer

  1. #1
    Join Date
    May 2014

    Default Requirements / dependencies for Qt4 Designer

    I successfully installed and can run Qt4 Designer on my desktop machine,
    which is a 64-bit system running Ubuntu 12.04 LTS. Now I am trying to
    install Qt4 Designer on a laptop that is very similar: 64-bit Ubuntu 12.04 LTS.
    Updates are regularly installed.
    However, when I install Qt4 Designer on the laptop (using the Ubuntu
    Software Center) and click on the icon in the launcher, the application
    simply does not start. I suspect that there is a library missing or an
    incompatible one installed on the laptop, and I've tried to compare what
    I have installed on the desktop and laptop to see whether there is any
    difference, but so far I have not been able to find what the problem is.
    Does anyone know of any obvious missing libraries, incompatibilities,
    wrong versions, etc., that could be responsible for this?
    Thanks in advance for any suggestions.

  2. #2
    Join Date
    May 2014

    Default Re: Requirements / dependencies for Qt4 Designer

    For what it's worth I noticed that there is one difference between the two installations:
    The desktop machine is running Ubuntu 12.04 LTS and the laptop is running 14.04 LTS.
    I've tried uninstalling and reinstalling Qt4 Designer many times, before and after adding
    and/or removing other packages. Help!

  3. #3
    Join Date
    May 2014

    Default Re: Requirements / dependencies for Qt4 Designer

    It was suggested that I try launching Qt4 Designer from the command line to see the error messages. I have tried that, and here is what I got:

    tom@Napoleon:~$ which designer-qt4
    tom@Napoleon:~$ designer-qt4 &
    [1] 10427
    tom@Napoleon:~$ makekdewidgets(10427)/libakonadi Akonadi::AgentManagerPrivate::createDBusInterface: AgentManager failed to get a valid AgentManager DBus interface. Error is: 1 "org.freedesktop.DBus.Error.NameHasNoOwner" "Could not get owner of name 'org.freedesktop.Akonadi.Control': no such name"
    designer-qt4: symbol lookup error: /usr/lib/x86_64-linux-gnu/qt4/plugins/designer/ undefined symbol: _ZN13QsciScintillaC1EP7QWidget

    [1]+ Exit 127 designer-qt4

    Does this mean anything to anyone? Thanks in advance for any suggestions. I'm getting desperate.

    Added after 1 4 minutes:

    I searched for the strings "undefined symbol:" _ZN13QsciScintillaC1EP7QWidget
    and found this bug report:
    Conclusion of the bug was:
    "So it seems the qscintilla package may need re-building after the qt4-4.8.5-8 release."
    I checked computer that was having the problem, and it had the qscintilla package installed.
    I simply uninstalled everything related to it, and then Qt4 Designer launched normally.
    Thanks to everyone who made suggestions.
    Last edited by tom.hedden; 16th May 2014 at 22:04.

Similar Threads

  1. QT4 vs QT2: hardware requirements
    By Yuri T in forum Qt for Embedded and Mobile
    Replies: 7
    Last Post: 9th December 2016, 09:52
  2. Immediate Requirements
    By rmymhn in forum Jobs
    Replies: 1
    Last Post: 24th March 2011, 05:35
  3. Qt for X11 requirements..
    By ML in forum Installation and Deployment
    Replies: 2
    Last Post: 18th February 2010, 00:37
  4. Memory Requirements of Qt
    By Svaths in forum Qt for Embedded and Mobile
    Replies: 1
    Last Post: 31st March 2007, 00:33
  5. Minimum requirements for application
    By b1 in forum Qt Programming
    Replies: 8
    Last Post: 17th September 2006, 23:29

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.