Results 1 to 2 of 2

Thread: Qt 5.5 android deployment - Exit code: 1

  1. #1
    Join Date
    Sep 2015
    Posts
    1
    Qt products
    Qt5
    Platforms
    MacOS X Unix/X11 Windows Android

    Default Qt 5.5 android deployment - Exit code: 1

    Hi guys

    First of all might I add that I am a huge Qt fan but the environment set up for android drives me nutts.
    Please help if you can.
    I can not for the life in me figure out why I can't deploy successfully to an android phone with debugging.

    Any app it doesn't matter which. Just a simple empty stock app will not compile with debugging to my phone.
    It compiles fine to the phone but when it gets to the launching of the app step on my android it just stops with the following errors.

    ----------------------------

    Copying GNU STL library
    -- Skipping file /home/theguy/android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/libs/armeabi-v7a/libgnustl_shared.so. Same or newer file already in place.
    Copying 490 dependencies from Qt into package.
    4181 KB/s (14281539 bytes in 3.335s)
    Installing Android package to device.
    Running command "/home/theguy/android/android-sdk/platform-tools/adb -s 9cc172fdedea install -r /home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/android-build//build/outputs/apk/android-build-debug.apk"
    open: Permission denied
    pkg: /data/local/tmp/android-build-debug.apk
    Success
    Android package built successfully in 14.128 ms.
    -- It can now be run from the selected device/emulator.
    -- File: /home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/android-build//build/outputs/apk/android-build-debug.apk
    20:51:13: The process "/home/theguy/V-PlaySDK/5.5/android_armv7/bin/androiddeployqt" exited normally.
    20:51:13: Pulling files necessary for debugging.
    20:51:13: Package deploy: Running command "/home/theguy/android/android-sdk/platform-tools/adb -s 9cc172fdedea pull /system/bin/sh: readlink: not found /home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/app_process".
    20:51:13: Packaging error: Command "/home/theguy/android/android-sdk/platform-tools/adb -s 9cc172fdedea pull /system/bin/sh: readlink: not found /home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/app_process" failed.Exit code: 1
    20:51:13: Package deploy: Failed to pull "/system/bin/sh: readlink: not found" to "/home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/app_process".
    20:51:13: Package deploy: Running command "/home/theguy/android/android-sdk/platform-tools/adb -s 9cc172fdedea pull /system/lib/libc.so /home/theguy/Desktop/Projects/vplay/build-TestApp-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Release/libc.so".
    Error while building/deploying project TestApp (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.5.0))
    When executing step "Deploy to Android device"

    ------------------------------

  2. #2
    Join Date
    Oct 2015
    Posts
    1
    Qt products
    Qt5
    Platforms
    Windows Android

    Default Re: Qt 5.5 android deployment - Exit code: 1

    I have the exact same problem. I have been trying to find a solution. The weird part is that all worked fine for me before. I made a simple application and released or debugged it to a Asus tablet I have, then suddenly when I deleted some of the build folders that gets made when you try to simulate or push our application to a device, it does not work anymore, and I get the same error as you.

    And now even if I make a new application, even on a different computer, I get the same errors.

    Please post here if you come across a solution.

    --------------------------------------------------------
    15:52:49: Packaging error: Command "D:/dokumenter/3klassedata/SmartSystems/Android/sdk/platform-tools/adb.exe -s C7OKAS180687 pull /system/bin/sh: readlink: not found D:/dokumenter/3klassedata/SmartSystems/Qt/Test/build-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/app_process" failed.Exit code: 1
    15:52:49: Package deploy: Failed to pull "/system/bin/sh: readlink: not found" to "D:/dokumenter/3klassedata/SmartSystems/Qt/Test/build-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/app_process".
    15:52:49: Package deploy: Running command "D:/dokumenter/3klassedata/SmartSystems/Android/sdk/platform-tools/adb.exe -s C7OKAS180687 pull /system/lib/libc.so D:/dokumenter/3klassedata/SmartSystems/Qt/Test/build-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/libc.so".
    Error while building/deploying project test (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.5.0))
    When executing step "Deploy to Android device"
    --------------------------------------------------------


    EDIT:

    I think I know what the problem is. https://bugreports.qt.io/browse/QTCREATORBUG-14201
    They talk about it in this bugreport. And from what I can understand it seem like this is a bug in version 3.5.0 of qt creator. And it should be fixed in the next version. I cant find the new version anywhere yet, and the newest version in the opensource version of qt is 3.5.0. So it seems we have to wait to get this sorted.
    Last edited by vegdji; 12th October 2015 at 17:24.

Similar Threads

  1. Getting 1073741502 exit code
    By ujwala in forum Newbie
    Replies: 2
    Last Post: 13th May 2013, 22:27
  2. [solved]jom exit with code 2 without any errors.
    By pkj in forum Qt Programming
    Replies: 0
    Last Post: 7th September 2012, 09:17
  3. Replies: 1
    Last Post: 13th September 2011, 10:56
  4. Exit Code 3
    By RSX in forum Newbie
    Replies: 4
    Last Post: 11th March 2011, 01:44
  5. Is there a guide for exit code messages?
    By tonnot in forum Newbie
    Replies: 13
    Last Post: 9th December 2010, 11:45

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.