Results 1 to 7 of 7

Thread: Qwt, Creator, RapberryPi Jessie

  1. #1
    Join Date
    Dec 2011
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Qwt, Creator, RapberryPi Jessie

    Hi,
    I had no troubles installing Qt, Creator and Qwt on Rasbian Wheezy. The installed version was
    Qt Creator 2.5.0
    Based on Qt 4.8.1

    Installation was done using:
    sudo apt-get install qt4-dev-tools libqt4-dev qt4-qmake g++ make qtcreator
    sudo apt-get install libqwt-dev libqwt-doc libqwt6
    Uncheck "remote linux" and "Welcome" in QtCreator -> "Help" -> "About Plugins" ,
    Adaption of toolchain in QtCreator

    Everything works fine: compiling of Qt & Qwt programs without problems, Qwt Widgets in QtCreator are OK

    BUT:
    Using Jessie and installing Qt and QtCreator version is changed to:
    Qt Creator 3.2.1
    Based on Qt 5.3.2 (GCC 4.9.1)
    I did not find a way to keep QtCreator 2.5 and Qt 4.8
    This seems to be incompatible with Qwt when installing as above: there are no widgets of Qwt in QtCreator any longer!
    Existing Qwt-programs can be compiled but working without widgets in QtCreator is annoying.
    I also tried to compile Qwt manually and copying *.so-files to the plugin directory, but I was not sucessful.

    So my question:
    Does anybody know how to keep QtCreator 2.5 and Qt 4.8 in Jessie,
    or how is Qwt installed correctly in Qt 5.3 and QtCreator 3.2

    Thank you
    Hans
    PS: I also put this problem into the forum of raspberrypi.org, but I did not get any answer.

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,545 Times in 1,495 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    I am pretty sure that Jessie still comes with Qt4, so that could be used with the newer QtCreator.

    You will also need qt4-designer to have a Qt Designer based on Qt4 to load the Qt4 QWT widget plugins.

    Cheers,
    _

  3. #3
    Join Date
    Dec 2011
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    Thank you for the quick reply.

    I used
    sudo apt-get install qt4-dev-tools
    sudo apt-get install qtcreator
    sudo apt-get install libqwt-dev libqwt-doc libqwt6

    There is a qt4-designer indeed and I there are QWT widgets in the designer too, but
    as I wrote I got: Qt Creator 3.2.1 Based on Qt 5.3.2 (GCC 4.9.1) and NO QWT widgets!
    Other widgets can be used and programs can be compiled!

    Any idea?
    Thanks, Hans

  4. #4
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,545 Times in 1,495 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    Quote Originally Posted by hgstoehr View Post
    There is a qt4-designer indeed and I there are QWT widgets in the designer too
    Excellent, so you're good?

    Quote Originally Posted by hgstoehr View Post
    as I wrote I got: Qt Creator 3.2.1 Based on Qt 5.3.2 (GCC 4.9.1) and NO QWT widgets!
    Right, as it is Qt5 based it can't load Qt4 based plugins.

    Doesn't matter since you have a designer matching your version of Qt.

    Cheers,
    _

  5. #5
    Join Date
    Dec 2011
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    Unfortunately there is an other issue concerning Qt Designer:
    using a remote connection to my notebook (SSH X11) it is not possible to drag and drop widgets! All other things work well!
    That's why I would prefer using Qt Creator: there are no drag and drop problems!

    Anyway, perhaps I have to wait for a newer QWT release!
    Hans

  6. #6
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,241
    Thanked 860 Times in 809 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    You have to install qwt-qt5 ( for the creator ) and qwt-qt4 ( for your application ). The output of the qwt-qt5 plugin should be readable for a qwt-qt4 based application.
    Waiting for a newer Qwt release won't help as Qwt 6.1.x supports all versions >= Qt 4.4 ( including all Qt5 versions ). What you need is a version of Qwt, hat has been built with a Qt version, that is compatible with the one your Creator has been built with

    Uwe

  7. #7
    Join Date
    Dec 2011
    Posts
    15
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qwt, Creator, RapberryPi Jessie

    Finally I got things running.
    I downloaded qwt-6.1.2 (sourceforge.net/projects/qwt/files/qwt/6.1.2/) --> /home/pi/qwt-6.1.2
    sudo apt-get install qt5-default
    sudo apt-get install libqt5svg5*
    sudo apt-get install qttools5-dev
    ~/qwt-6.1.2 $ qmake qwt.pro
    ~/qwt-6.1.2 $ make
    ~/qwt-6.1.2 $ sudo make install
    cd /usr/local/qwt-6.1.2/plugins/designer
    sudo cp /usr/local/qwt-6.1.2/plugins/designer/libqwtdesignerplugin.so /usr/lib/arm-linux-gnueabihf/qt5/plugins/designer

    Hans

Similar Threads

  1. Replies: 5
    Last Post: 1st July 2015, 14:04
  2. Replies: 10
    Last Post: 16th June 2014, 15:40
  3. Replies: 1
    Last Post: 12th June 2014, 07:37
  4. Replies: 2
    Last Post: 11th June 2014, 08:17
  5. Replies: 2
    Last Post: 22nd November 2011, 00:09

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.