Results 1 to 3 of 3

Thread: Qt application failed to run in a Pc without QT (windeployqt used)

  1. #1
    Join Date
    Apr 2013
    Posts
    61
    Qt products
    Qt4
    Platforms
    Windows

    Default Qt application failed to run in a Pc without QT (windeployqt used)

    Hi,

    I hace a QT 5.7 (VS 2013) app running properly in my Pc (with QT installed), and I want to launch it in a Pc without QT.

    I have used 'windeployqt' to add all required libraries and folders to my binary path, and a lot of them have been added there.

    I rename the 'QT' folder, to simulate another Pc, and I launch the .exe, but it fails:

    Qt WebEngine ICU data not found at C:/Qt/5.7/msvc2013/resources. Trying parent directory...
    Qt WebEngine ICU data not found at C:/Qt/5.7/msvc2013. Trying application directory...
    Qt WebEngine ICU data not found at D:/Projects/SpontaniaQML/Spontania-Desktop/Release. Trying fallback directory... The application MAY NOT work.
    ModLoad: 00000000`0e8e0000 00000000`0e981000 C:\Windows\SysWOW64\advapi32.dll
    ModLoad: 00000000`0e8e0000 00000000`0e8f7000 C:\Windows\SysWOW64\userenv.dll
    Installed Qt WebEngine locales directory not found at location C:/Qt/5.7/msvc2013/translations\qtwebengine_locales. Trying application directory...
    (bfc.1ca4): WOW64 breakpoint - code 4000001f (first chance)
    First chance exceptions are reported before any exception handling.
    This exception may be expected and handled.
    *** WARNING: Unable to verify checksum for D:\Projects\MyProject\Release\Qt5WebEngineCore.dll
    *** ERROR: Symbol file could not be found. Defaulted to export symbols for D:\Projects\MyProject\Release\Qt5WebEngineCore.dll -
    Qt5WebEngineCore!GetHandleVerifier+0x22c71:
    579c8d61 cc int 3

    It is a ICU problem? I have NOt found any of these libraries in my QT path to add to my binary folder...

    Thanks in advance,

    Diego

  2. #2
    Join Date
    Mar 2008
    Location
    Kraków, Poland
    Posts
    1,528
    Thanked 279 Times in 274 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Qt application failed to run in a Pc without QT (windeployqt used)


  3. #3
    Join Date
    Apr 2013
    Posts
    61
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qt application failed to run in a Pc without QT (windeployqt used)

    I have found my problem. In my PATH variable I had references to QT 5.5, not to QT 5.7. Updated that, the app runs properly

Similar Threads

  1. Replies: 1
    Last Post: 19th April 2016, 18:38
  2. Replies: 4
    Last Post: 7th October 2015, 08:47
  3. Replies: 11
    Last Post: 1st September 2014, 14:12
  4. QProcess::start() failed when application runs from sudo
    By alenyashka in forum Qt Programming
    Replies: 3
    Last Post: 22nd June 2010, 07:35
  5. Replies: 2
    Last Post: 26th February 2010, 01:29

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.