Results 1 to 4 of 4

Thread: Qt5.8 - incompatible library problem

  1. #1
    Join Date
    Aug 2009
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11

    Default Qt5.8 - incompatible library problem

    I am currently running Mint 17.2 with Qt 5.2.1, which for various reasons I don't want to uninstall. However, wanting to try the latest release, I used the Qt downloader to install 5.8 in $HOME/Qt, as suggested. At the end of the install, it asks whether to run qtcreator; I did and it looked fine. But after exiting, any attempt to rerun gives the message:

    Qt Code:
    1. tonyb@new-laptop ~ $ ~/Qt/Tools/QtCreator/bin/qtcreator
    2. Cannot mix incompatible Qt library (version 0x50201) with this library (version 0x50800)
    3. Aborted
    To copy to clipboard, switch view to plain text mode 

    I get the same result if I run the shell script provided with the binary. I have ascertained that the shell script sets LD_LIBRARY_PATH to:
    /home/tonyb/Qt/Tools/QtCreator/lib:/home/tonyb/Qt/Tools/QtCreator/lib/qtcreator:/home/tonyb/Qt/Tools/QtCreator/lib/Qt/lib

    I get the follwoing output from ldd:
    Qt Code:
    1. tonyb@new-laptop ~ $ ldd ~/Qt/Tools/QtCreator/bin/qtcreator
    2. linux-vdso.so.1 => (0x00007ffd6ffb2000)
    3. libExtensionSystem.so.4 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/qtcreator/libExtensionSystem.so.4 (0x00007f9cea939000)
    4. libAggregation.so.4 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/qtcreator/libAggregation.so.4 (0x00007f9cea732000)
    5. libUtils.so.4 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/qtcreator/libUtils.so.4 (0x00007f9cea365000)
    6. libQt5Widgets.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libQt5Widgets.so.5 (0x00007f9ce9b34000)
    7. libQt5Gui.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libQt5Gui.so.5 (0x00007f9ce9398000)
    8. libQt5Concurrent.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libQt5Concurrent.so.5 (0x00007f9ce9191000)
    9. libQt5Network.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libQt5Network.so.5 (0x00007f9ce8e0b000)
    10. libQt5Core.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libQt5Core.so.5 (0x00007f9ce86ea000)
    11. libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f9ce845d000)
    12. libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9ce823f000)
    13. libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f9ce7f3a000)
    14. libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f9ce7c34000)
    15. libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f9ce7a1e000)
    16. libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9ce7658000)
    17. libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f9ce7454000)
    18. libQt5Qml.so.5 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/qtcreator/../Qt/lib/libQt5Qml.so.5 (0x00007f9ce6e58000)
    19. libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f9ce6c3f000)
    20. libicui18n.so.56 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libicui18n.so.56 (0x00007f9ce67a4000)
    21. libicuuc.so.56 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libicuuc.so.56 (0x00007f9ce63ec000)
    22. libicudata.so.56 => /home/tonyb/Qt/Tools/QtCreator/bin/../lib/Qt/lib/libicudata.so.56 (0x00007f9ce4a09000)
    23. librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f9ce4800000)
    24. libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f9ce45fe000)
    25. libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f9ce42f6000)
    26. /lib64/ld-linux-x86-64.so.2 (0x00007f9ceab7f000)
    27. libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f9ce40ce000)
    28. libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f9ce3ebc000)
    29. libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f9ce3cb9000)
    30. libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f9ce3ab2000)
    31. libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f9ce38b0000)
    32. libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f9ce357b000)
    33. libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f9ce3363000)
    34. libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f9ce315e000)
    35. libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f9ce2f5b000)
    36. libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f9ce2d57000)
    37. libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f9ce2b51000)
    38. libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f9ce2932000)
    39. libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f9ce272f000)
    40. libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f9ce2529000)
    41. libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f9ce231b000)
    42. libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f9ce20dc000)
    43. libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f9ce1ed7000)
    44. libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f9ce1cd1000)
    To copy to clipboard, switch view to plain text mode 

    Trying the same thing under Ubuntu 16.04 with Qt5.5.1, I get similar output.

    Qt Code:
    1. tonyb@tonyb-SharkBay:~$ /homex/tonyb/Qt/Tools/QtCreator/bin/qtcreator
    2. QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
    3. QApplication: invalid style override passed, ignoring it.
    4. Cannot mix incompatible Qt library (version 0x50501) with this library (version 0x50800)
    5. Aborted (core dumped)
    To copy to clipboard, switch view to plain text mode 

    Any ideas how I can debug further?

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,420
    Thanks
    37
    Thanked 1,545 Times in 1,495 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Qt5.8 - incompatible library problem

    Maybe it is trying to load a platform theme integration plugin.

    You could try setting the QT_DEBUG_PLUGINS environment variable to any non zero value and see if you get any more detailed output during startup.

    Cheers,
    _

  3. #3
    Join Date
    Aug 2009
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11

    Default [Solved] Qt5.8 - incompatible library problem

    Oops - my mistake. I had an old QT_PLUGIN_PATH in my environment. I thought I'd checked that before posting. I must be getting old.

  4. #4
    Join Date
    Apr 2017
    Posts
    1
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: [Solved] Qt5.8 - incompatible library problem

    i have same ERROR : QApplication: invalid style override passed, ignoring it.
    in linux mint 18 , QT 5.8
    how can i fix it?

    i am new in QT

Similar Threads

  1. Replies: 0
    Last Post: 21st November 2012, 18:11
  2. Replies: 6
    Last Post: 31st July 2012, 20:35
  3. Cannot mix incompatible Qt library
    By ycyclop in forum Installation and Deployment
    Replies: 0
    Last Post: 12th March 2012, 13:01
  4. Cannot mix incompatible Qt library
    By hubipet in forum Qt Programming
    Replies: 4
    Last Post: 13th February 2012, 19:03
  5. Loading plugin and "Incompatible Qt library" issue.
    By TorAn in forum Qt Programming
    Replies: 4
    Last Post: 31st May 2010, 13:04

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.