Results 1 to 2 of 2

Thread: libGL.so.1 not found:Qt GUI app in docker with centos

  1. #1
    Join Date
    May 2017
    Posts
    9
    Thanks
    2
    Qt products
    Qt5
    Platforms
    MacOS X Windows

    Default libGL.so.1 not found:Qt GUI app in docker with centos

    Hello,

    I am trying to run a Qt app in docker. I have a very limited linux experience. The OS is centos. Qt version is 5.9.1. The overall idea is to run it in Xvbf.

    When I try "docker run -it myTestGuiApp", I get an error libGL.so.1: cannot open shared object file: No such file or directory. What is missing here?

    Thanks in advance.

  2. #2
    Join Date
    Jan 2008
    Location
    Alameda, CA, USA
    Posts
    3,940
    Thanks
    231
    Thanked 619 Times in 609 Posts
    Qt products
    Qt5
    Platforms
    Unix/X11 Windows Android

    Default Re: libGL.so.1 not found:Qt GUI app in docker with centos

    What is missing here?
    libGL.so.1

    Probably your docker configuration doesn't contain the OpenGL library, you haven't configured docker correctly so it can find the shared libraries at runtime, you have built and linked your application (or Qt) against a different OpenGL version than you have installed on CentOS, or any number of things.

    This doesn't sound like a Qt problem, it sounds like a docker problem. You should post your question on a docker forum if there is one.
    <=== The Great Pumpkin says ===>
    Please use CODE tags when posting source code so it is more readable. Click "Go Advanced" and then the "#" icon to insert the tags. Paste your code between them.

Similar Threads

  1. libGL/QOpenGLShader errors when starting QtQuick application
    By JamesNZ in forum Installation and Deployment
    Replies: 0
    Last Post: 2nd January 2015, 05:10
  2. QTCreator crashes on start libgl error
    By enricong in forum Qt Tools
    Replies: 0
    Last Post: 22nd May 2014, 13:50
  3. missing libGL.so.1
    By Brent.Allsop in forum Newbie
    Replies: 1
    Last Post: 5th February 2014, 04:33
  4. libGL using memory in console application
    By neuron in forum Qt Programming
    Replies: 0
    Last Post: 11th March 2009, 15:52
  5. Using QT in CentOS
    By vishakvkurup in forum Qt Programming
    Replies: 7
    Last Post: 15th January 2008, 22:01

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.