Results 1 to 1 of 1

Thread: How to implement Warp7 sample as same as sample in QtWS16

  1. #1
    Join Date
    Dec 2017
    Qt products
    Qt5 Qt/Embedded
    MacOS X Unix/X11 Windows Android

    Unhappy How to implement Warp7 sample as same as sample in QtWS16

    Hi everyone

    Please help me in case below.
    I see this video on youtube ( which is showing that Boot2Qt is working on NXP WaRP7 with QTLite 5.8

    I 've bought WaRP7 & its LCD display but I can not make it work (display something on screen).
    Sorry for my noob question:

    how can I made a sample exactly the same in video ?
    I try many ways but failed, since I'm just dive in embedded only for 2 months and still don't know where to start.
    It is many thanks if anyone can figure out is there any problems with any my solutions below ?
    I tried to use Boot2Qt in Qt 5.9.2, 5.10 & build Wearable example on it.
    When I run sample, there is nothing display but only error on command line

    1st try:
    run command
    export QT_QPA_PLATFORM=linuxfb
    export QMLSCENE_DEVICE=softwarecontext
    => command line is running and show like application is running (compare with sample on raspberryPi3) but nothing display

    2nd try:
    run only /data/user/qt/wearable/wearable
    => error show:
    QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
    Could not open egl display
    Aborted(code dumped)

    3rd try:
    I used fsl-multimedia BSP of Yocto project to boot on my WaRP7.
    I run command "export DISPLAY=localhost:0.0" & execute application
    => There is no error.
    I try to find resolution by command "xrandr -q"
    => error: error message: Can't open display localhost:0.0

    4th try:
    I used QtLite 5.8 with Yocto build (bitbake core-image-base & core-image-sato). But no hope as well.

    Other tries: I try to use fbtft driver to drive LCD, also try to boot display via SPI and many other configuration for weeks. But display still BLACK

    Thank you for your reading time.

    Note: sorry if my english confuse you.
    Last edited by nntchau; 8th December 2017 at 09:11.

Similar Threads

  1. QUdpSocket sample code
    By alimooghashang in forum Qt Programming
    Replies: 3
    Last Post: 14th November 2013, 21:59
  2. Replies: 2
    Last Post: 27th August 2012, 07:08
  3. UTF-8 Issues in Sample
    By trevelyan in forum Newbie
    Replies: 6
    Last Post: 19th May 2011, 02:41
  4. Replies: 4
    Last Post: 18th November 2010, 14:00
  5. Sample for Mutithreading
    By HugoHiasl in forum Qt Programming
    Replies: 19
    Last Post: 1st July 2010, 08:43


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.