Results 1 to 3 of 3

Thread: QSerialPort issue, cant find the PCI device

  1. #1
    Join Date
    Jul 2018
    Posts
    3
    Qt products
    Qt5
    Platforms
    Unix/X11

    Question QSerialPort issue, cant find the PCI device

    Hi everybody, I'm new to the forum so if I didn't respect some rules, please forgive me. Now here we go.

    I'm trying to communicate with a PCI card on my PC, I used the QSerialPort and QSerialPortInfo to do it. FYI, I'm working with Linux Ubuntu 18.04 kernel 4.15.0-23.

    I use this code to show all available ports on my PC:

    Qt Code:
    1. foreach (const QSerialPortInfo &info, QSerialPortInfo::availablePorts()){
    2. ui->comboBox->addItem(info.portName());
    3. qDebug() << "Name : " << info.portName();
    4. qDebug() << "Description : " << info.description();
    5. qDebug() << "Manufacturer: " << info.manufacturer();
    6. }
    To copy to clipboard, switch view to plain text mode 

    And I find two port: ttyS0 and ttyS4, but none of them linked to my PCI card, because I tried to unplug the PCI card and these two port were also there.
    So I guess that my program didn't find the card, I've done a little research on the internet, I got this: https://bugreports.qt.io/browse/QTBUG-35064
    In this post, the guy had the same issue like me but I'm not a expert so I cant fully understand the reason and also don't know how to resolve it, it seems like qt under linux don't support PCI port? I'm not sure about it, if this is the case, how can I communicate with the PCI port?

    Hope somebody can help, many thanks in advance!

  2. #2
    Join Date
    Jul 2008
    Posts
    406
    Thanks
    9
    Thanked 52 Times in 50 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: QSerialPort issue, cant find the PCI device

    Hi, does your card work with other programs?
    Does it help to run your program with root privileges?

    Ginsengelf

  3. #3
    Join Date
    Jul 2018
    Posts
    3
    Qt products
    Qt5
    Platforms
    Unix/X11

    Question Re: QSerialPort issue, cant find the PCI device

    Hi Ginsengelf,
    Thanks for your fast reply.
    My card is a cameralink frame grabber, I can receive images from the camera via this card so I think it can work properly. A stupid question, how can I run my program as root in qtcreator debug mode?

    Edit:
    I've tried to run as root but there are no difference..

    Edit:
    I can find the PCI device with command 'dmesg' and 'lspci':

    dmesg:
    Qt Code:
    1. [ 4.617179] pci 0000:04:00.0: [1805:030a] type 00 class 0x118000
    To copy to clipboard, switch view to plain text mode 

    lspci:
    Qt Code:
    1. 04:00.0 Signal processing controller: Euresys S.A. Device 030a (rev 8a)
    To copy to clipboard, switch view to plain text mode 
    Last edited by gcai; 3rd July 2018 at 12:10.

Similar Threads

  1. Replies: 1
    Last Post: 29th June 2018, 10:24
  2. Replies: 29
    Last Post: 24th January 2017, 12:30
  3. Replies: 5
    Last Post: 17th April 2015, 07:09
  4. QAudioDeviceInfo availableDevices can not find sound device in embeded arm
    By xstream71 in forum Qt for Embedded and Mobile
    Replies: 1
    Last Post: 29th September 2014, 14:16
  5. Qserialport issue in QT4
    By coss_cat in forum Qt Programming
    Replies: 3
    Last Post: 11th December 2013, 18:11

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.