Results 1 to 4 of 4

Thread: Problem with generating ui_*.h

  1. #1
    Join Date
    Mar 2008
    Location
    Kraków, Poland
    Posts
    1,430
    Thanked 264 Times in 259 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Problem with generating ui_*.h

    Qt 5.10 on Windows with VS 2015.
    ui_*.h have empty tool tips, status tips and whats this tip for QCheckBox.
    Qt Code:
    1. #ifndef QT_NO_TOOLTIP
    2. m_checkBox->setToolTip(QString());
    3. #endif // QT_NO_TOOLTIP
    4. #ifndef QT_NO_STATUSTIP
    5. m_checkBox->setStatusTip(QString());
    6. #endif // QT_NO_STATUSTIP
    7. #ifndef QT_NO_WHATSTHIS
    8. m_checkBox->setWhatsThis(QString());
    9. #endif // QT_NO_WHATSTHIS
    To copy to clipboard, switch view to plain text mode 
    In UI file is :
    Qt Code:
    1. <widget class="QCheckBox" name="m_checkBox">
    2. <property name="toolTip">
    3. <string extracomment="Ala ma kota"/>
    4. </property>
    5. <property name="statusTip">
    6. <string extracomment="Ala ma kota"/>
    7. </property>
    8. <property name="whatsThis">
    9. <string extracomment="Ala ma kota"/>
    10. </property>
    11. <property name="text">
    12. <string>Bla bla bla....</string>
    13. </property>
    14. </widget>
    To copy to clipboard, switch view to plain text mode 

    With Qt 4.8 generated ui_*.h files is OK. Whether it is a mistake or intended behavior ?

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,183
    Thanks
    36
    Thanked 1,489 Times in 1,441 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Problem with generating ui_*.h

    The XML has empty <string> elements for the content of the three tips.

    The tip text is the character data between the opening and the closing <string> tag
    Qt Code:
    1. <property name="toolTip">
    2. <string extracomment="Ala ma kota">Tool Tip Text Here</string>
    3. </property>
    To copy to clipboard, switch view to plain text mode 

  3. #3
    Join Date
    Mar 2008
    Location
    Kraków, Poland
    Posts
    1,430
    Thanked 264 Times in 259 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Problem with generating ui_*.h

    Thanks anda_skoa. I think I have to go to an ophthalmologist

  4. #4

    Default Re: Problem with generating ui_*.h

    Thanks, helped me too

Similar Threads

  1. In Qt5 not generating .exe file
    By Karthik AS in forum Newbie
    Replies: 2
    Last Post: 23rd April 2016, 13:51
  2. Generating SVG
    By beekeep in forum Qt Programming
    Replies: 0
    Last Post: 7th January 2010, 18:55
  3. Generating .bmp file
    By aj2903 in forum Qt Programming
    Replies: 4
    Last Post: 12th November 2009, 09:42
  4. Qmake: Problem generating msvc solutions.
    By dead1ock in forum Qt Programming
    Replies: 0
    Last Post: 4th October 2009, 04:28
  5. Generating Log files
    By srohit24 in forum Qt Programming
    Replies: 12
    Last Post: 15th July 2009, 08:57

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.