Results 1 to 4 of 4

Thread: Slow tooltips while debugging

  1. #1
    Join Date
    Apr 2019
    Posts
    3
    Qt products
    Qt5
    Platforms
    MacOS X Windows

    Question Slow tooltips while debugging

    I'm using tooltips pretty extensively in my Qt project. (Qt 5.12.2, using Qt Creator on Windows 10.)
    While debugging, which I am currently doing 99% of the time, the tooltips are loading up very slowly, and in fact show up clipped at first, and then redraw correctly. While the tooltips are loading up, the debugger view of Qt Creator is showing a sequence of DLL's loading up. I think that the loading of these DLL's is slow for some reason, and is the reason for the painfully slow tooltips.
    If someone could help me figure out something I might be able to change or fix to work around this slow loading, it would greatly help me with my development.
    Attached is a screen capture of the loading sequence, and one of the DLL's names.
    Thanks,
    -Steve Lamperti
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,356
    Thanks
    3
    Thanked 5,010 Times in 4,789 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Blog Entries
    4
    Wiki edits
    10

    Default Re: Slow tooltips while debugging

    What do the tooltips look like?
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3
    Join Date
    Apr 2019
    Posts
    3
    Qt products
    Qt5
    Platforms
    MacOS X Windows

    Default Re: Slow tooltips while debugging

    Attached are two screen shots. The first shows how the tool tip initially appears, and the second how it shows after a little bit longer.
    Cropped.png
    Not Cropped.png

    By the way, I did some more research, and the DLL's that are loading up while I am waiting for the tooltips to appear are associated with OpenGL drivers for an Intel based video card built into my machine. I have a dual monitor set up, and one of the monitors is plugged into an nVidea card in the machine, and the other is plugged into the build in Intel video. This seems to not be causing me any issues, as far as I can tell.

  4. #4
    Join Date
    Apr 2019
    Posts
    3
    Qt products
    Qt5
    Platforms
    MacOS X Windows

    Default Re: Slow tooltips while debugging

    Good news. I just loaded up 5.12.3, and the issue seems to be gone. Must have been something in Qt creator, I guess. Looks like it's working better now.

Similar Threads

  1. Qt Creator Debugging extremely slow
    By GMouzon in forum Qt Tools
    Replies: 4
    Last Post: 28th September 2015, 23:15
  2. Qt, Visual Studio 2013, and slow debugging
    By d_stranz in forum Qt Programming
    Replies: 4
    Last Post: 3rd July 2015, 09:08
  3. how i use the tooltips
    By robelle in forum Qt Programming
    Replies: 5
    Last Post: 24th September 2012, 15:51
  4. Replies: 3
    Last Post: 6th September 2010, 23:00
  5. toolTips?
    By mickey in forum Qt Programming
    Replies: 11
    Last Post: 23rd February 2006, 19:10

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.