Results 1 to 1 of 1

Thread: Error Unknown Module(s) in QT: plugin

  1. #1
    Join Date
    Dec 2019
    Qt products
    MacOS X Unix/X11

    Default Re: Error Unknown Module(s) in QT: plugin

    I'm running QT on a Raspberry Pi4 with Buster. I used apt-get to install the official release of QT 5.11.3. I can create an application, compile and run without issues. That is until I add "plugin" to my .pro file on the QT tag. Immediately after saving and closing the .pro file, I get the message ERROR Unknown Module(s) in QT: plugin. Obviously there is a missing library. I searched the repository for packages that may apply, but didn't see anything that looked relevant. All of the designer packages that I tried were already installed. It would nice if error messages like this would actually say what modules were missing, but they don't. So my question is: what libraries or packages are needed for the plugin subsystem to work? I'd really like to not compile Qt from source. I did have a pre-compiled Qt 5.12 LTS on the system where the plugin module worked. It didn't have support for Bluetooth though which I need. Is plugin support something that needs to be configured into the build like bluetooth?

    Added after 1 28 minutes:

    I installed qttools5-dev, qttools5-dev-tools and qttools5-private-dev. This resolved the problem.
    Last edited by -johnf-; 15th December 2019 at 01:43.

Similar Threads

  1. Project ERROR: Unknown module(s) in QT: mqtt
    By akkarachai in forum Newbie
    Replies: 3
    Last Post: 16th February 2020, 16:43
  2. Replies: 4
    Last Post: 24th April 2019, 10:36
  3. Project ERROR: Unknown module(s) in QT: quick
    By Raghaw in forum Qt Quick
    Replies: 0
    Last Post: 4th December 2013, 05:56
  4. error: Unknown module(s) in QT: thread
    By gaganbm in forum Qt Tools
    Replies: 2
    Last Post: 15th March 2013, 14:56
  5. error: Unknown module(s) in QT: serialport
    By aguleo in forum Newbie
    Replies: 4
    Last Post: 11th March 2013, 21:54

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.