Hi Everyone,

has anyone tried to use a Bullet Simulation within a QTProject? Unfortunately I figured out a weird probelm:

The QtProject as well as the Simulation run fine, when launched via QtCreator. Since I had some other issues in the beginning I am compiling the Bullet Simulation (https://github.com/bulletphysics/bullet3) into a separate class using cmake (as suggested by the author) and include it as shared library. However, the main which instantiates the simulation class is compiled with qmake and runs fine, when launched alone.
The weird coincidence is, when I call
Qt Code:
  1. QApplication a(argc, argv);
To copy to clipboard, switch view to plain text mode 
before my simulation, which basically brings the xml-parser of bullet to break. All input values get casted to integer and objects smaller than one meter are infinitesimal small. Has anyone worked with this combination of C++ Bullet API (https://github.com/bulletphysics/bul...torClientAPI.h) and QApplication and can tell me what is going/am I doing wrong?

The last time I asked the question it just never got posted and I can not find it over the search, if I am producing a duplicate I apologize.