Results 1 to 4 of 4

Thread: Qt 5.15.0 WebEngineView not displaying PDF

  1. #1
    Join Date
    Oct 2010
    Posts
    9
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Qt 5.15.0 WebEngineView not displaying PDF

    I was using Qt 5.14.2 to display local PDF files successfully using WebEngineView. (I'm on CentOS 7)

    Then I updated to Qt 5.15.0 and my WebEngineView showed a blank gray screen.
    Then I ran an example of WebEngineView provided by Qt 5.15.0 and I got the same blank gray screen. However I got half a dozen error messages like the following one:

    "GET chrome-extension://mhjfbmdgcfjbbpaeojofohoefgiehjai/elements/viewer-error-screen.js net::ERR_FILE_NOT_FOUND"

    Am I missing something?

  2. #2
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,641
    Thanks
    13
    Thanked 1,592 Times in 1,520 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: Qt 5.15.0 WebEngineView not displaying PDF

    Have you turned on loading plugins and the PDF viewer?
    https://doc.qt.io/qt-5/qtwebengine-f...f-file-viewing

  3. #3
    Join Date
    Oct 2010
    Posts
    9
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: Qt 5.15.0 WebEngineView not displaying PDF

    Yes I have.
    I did a quick test. I ran the qt example quicknanobrowser with qt 15.4 and it displayed PDF fine. Then I ran the same example with 15.5 and I got blank gray screen.

  4. #4
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,641
    Thanks
    13
    Thanked 1,592 Times in 1,520 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: Qt 5.15.0 WebEngineView not displaying PDF

    Same here if I use the binaries distributed by the online installer.
    My best guess is that the package is missing the resource files that provide the Javascript for the PDF viewer, or that the behaviour is the result of the deprecation warned of in the 5.14.2 version:
    js: HTML Imports is deprecated and will be removed in M80, around February 2020. Please use ES modules instead. See https://www.chromestatus.com/features/5144752345317376 and https://developers.google.com/web/up...ime-to-upgrade for more details.

Similar Threads

  1. WebEngineView PDF viewing
    By youngw in forum Qt Quick
    Replies: 0
    Last Post: 9th May 2020, 19:28
  2. Webengineview not loading videos
    By A9am in forum Qt Quick
    Replies: 2
    Last Post: 2nd August 2017, 10:56
  3. WebEngineView - highlight issue.
    By ejoshva in forum Newbie
    Replies: 0
    Last Post: 14th July 2015, 12:29
  4. WebEngineView->findText()
    By ejoshva in forum Newbie
    Replies: 3
    Last Post: 17th June 2015, 12:10
  5. Mouseevents on a QwebView or WebEngineView
    By Tinu in forum Qt Programming
    Replies: 5
    Last Post: 8th April 2015, 08:51

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.