Already asked that question on stack overflow, but without any result. May be the question is incorrect in some way, correct me in that case.
I'm not sure either it's some kind of bug\glitch or I'm doing something wrong. I have some hidden rows in the table and on click I want them to appear but result you can see on the picture below.
That how it looks before click:
Screenshot from 2020-07-14 23-13-25.png
That how it looks after click:
Screenshot from 2020-07-14 23-14-47.png
Here the video of how does it look like:

This effect occurs only when slider is scrolled till the end. Glitch disappears if I change focus to another window or when I scroll table up until it goes out of view.

Here is my code:
Qt Code:
  1. connect(tableView_, SIGNAL(clicked(const QModelIndex &)), this,
  2. SLOT(onTableClicked(const QModelIndex &)));
  4. for(int i = 0; i < table_->rowCount(); i++)
  5. {
  6. if(i%table_->typesNumber())
  7. tableView_->hideRow(i);
  8. }
  10. ...
  12. void DumpsComparisonWindow::onTableClicked(const QModelIndex& index)
  13. {
  14. ...
  15. tableView_->showRow(index.row() + i);
  16. ...
  17. }
To copy to clipboard, switch view to plain text mode 
I have already tried tableView_->update() and tableView->repaint(), none of them worked.
I also created git repo to test code:
Thank you in advance for any hint!