Results 1 to 6 of 6

Thread: <type_traits> file not found while building qwt6.1.4

  1. #1
    Join Date
    May 2021
    Posts
    4
    Thanks
    2
    Qt products
    Qt5
    Platforms
    Windows

    Question <type_traits> file not found while building qwt6.1.4

    Hi, I'm trying to build qwt.lib and qwtd.lib from source files on Windows 10, using Qt 5.15 MSVC 2019 kit. I have Windows 10 SDK also installed.
    After running qmake, I'm running nmake. nmake can not find the file <type_traits>. This file is located in C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.28.29910\in clude which is in the PATH. This file is being called from C:\Qt\5.15.4\msvc2019\include\QtCore\qglobal.h.

    Running into build issues even with Qt Creator -> Build option after running qmake once.

    How to solve this issue?
    Last edited by ManiQt; 21st May 2021 at 12:13.

  2. #2
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,274
    Thanked 868 Times in 817 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: <type_traits> file not found while building qwt6.1.4

    As the include is made in qglobal.h this problem should have nothing to do with Qwt and you will have it with any type of Qt application.

    HTH,
    Uwe

  3. The following user says thank you to Uwe for this useful post:

    ManiQt (24th May 2021)

  4. #3
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,730
    Thanks
    13
    Thanked 1,610 Times in 1,537 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: <type_traits> file not found while building qwt6.1.4

    Quote Originally Posted by ManiQt View Post
    How to solve this issue?
    Are you running this from a command prompt set up by the batch file that is supplied with the Microsoft compiler (vcvars32.bat or vsvar32.bat or something like that)? Include files are not searched on the PATH. The Microsoft compiler uses a whole bunch of environment variables, one of which probably sets the include search path.
    "We can't solve problems by using the same kind of thinking we used when we created them." -- Einstein
    If you are posting code then please use [code] [/code] tags around it - makes addressing the problem easier.

  5. The following user says thank you to ChrisW67 for this useful post:

    ManiQt (24th May 2021)

  6. #4
    Join Date
    May 2021
    Posts
    4
    Thanks
    2
    Qt products
    Qt5
    Platforms
    Windows

    Default Re: <type_traits> file not found while building qwt6.1.4

    Hi Uwe and Chris, this problem didn't come up by using 6.2 version of qwt somehow. I tried building 6.1.4 on Qt Creator and CMD either of them gave compilation errors. In this forum I guess someone suggested to use qwt 6.2 instead and it worked. This time I have only tried on Qt Creator and build was successful with some handful of warnings regarding qwt_math.h as I recollect.

    To Chris- I tried regular method (nmake in Path) and also using vcvars32.bat method. Error occurred either way.

  7. #5
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,274
    Thanked 868 Times in 817 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: <type_traits> file not found while building qwt6.1.4

    Again: an error in qglobal.h is totally unrelated to whatever Qwt version you are using.

    Uwe

  8. #6
    Join Date
    May 2021
    Posts
    4
    Thanks
    2
    Qt products
    Qt5
    Platforms
    Windows

    Default Re: <type_traits> file not found while building qwt6.1.4

    Quote Originally Posted by Uwe View Post
    Again: an error in qglobal.h is totally unrelated to whatever Qwt version you are using.

    Uwe
    Yes, I understood qglobal.h is related to Qt and not Qwt. I am just clarifying what fixed the issue although the solution is very unnatural .

Similar Threads

  1. File not found msvcprtd.lib QT
    By davinciomare in forum Newbie
    Replies: 4
    Last Post: 30th September 2016, 01:04
  2. Replies: 0
    Last Post: 23rd March 2015, 12:15
  3. ui_mainwindow.h file not found
    By unix7777 in forum Qt Programming
    Replies: 4
    Last Post: 17th February 2013, 18:50
  4. Replies: 4
    Last Post: 25th July 2012, 08:26
  5. QSqlDataBase file not found
    By sdastagirmca in forum Qt Programming
    Replies: 3
    Last Post: 5th February 2009, 07:53

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.