Results 1 to 8 of 8

Thread: Problem with installing Qt 4.15.1 on CentOS6

  1. #1
    Join Date
    Apr 2021
    Posts
    27
    Thanks
    5

    Default Problem with installing Qt 4.15.1 on CentOS6

    I am installing the Qt4.15.1 on CentOS6 using this https://download.qt.io/official_rele...r/4.15/4.15.1/.

    But I am getting the following error.

    Can somebody tell me that how can I fix this issue?
    Attached Images Attached Images

  2. #2
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    474
    Thanks
    10
    Thanked 62 Times in 60 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Hi, you need to install the package that contains the required library libxkbcommon. You should be able to find it in the software repositories.

    Ginsengelf

  3. #3
    Join Date
    Apr 2021
    Posts
    27
    Thanks
    5

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Quote Originally Posted by Ginsengelf View Post
    Hi, you need to install the package that contains the required library libxkbcommon. You should be able to find it in the software repositories.

    Ginsengelf
    I used the following command to install the package issue.
    #yum install libxkbcommon-x11-devel

    However, I am still getting the same error.

  4. #4
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    474
    Thanks
    10
    Thanked 62 Times in 60 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Hi, you don't need the -devel package. The -devel packages contain the files that are necessary for development and compilation. But you only want to run an executable.
    The .so file that is missing should be part of libxkbcommon-x11 (on my openSUSE it's called "libxkbcommon-x11-0").

    Ginsengelf

  5. #5
    Join Date
    Apr 2021
    Posts
    27
    Thanks
    5

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Quote Originally Posted by Ginsengelf View Post
    Hi, you don't need the -devel package. The -devel packages contain the files that are necessary for development and compilation. But you only want to run an executable.
    The .so file that is missing should be part of libxkbcommon-x11 (on my openSUSE it's called "libxkbcommon-x11-0").

    Ginsengelf
    Hi, I used the following command to install libxkbcommon-x11 package but it says no package available on Centos 6.
    # yum install libxkbcommon-x11

  6. #6
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    552
    Thanked 86 Times in 81 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Use an older QtCreator (not Qt btw) - QtCreator 4.15 is build with Qt5.15 which does not support this old CentOS - see https://doc.qt.io/qt-5/supported-platforms.html

  7. The following user says thank you to ChristianEhrlicher for this useful post:

    Mohsin (7th July 2021)

  8. #7
    Join Date
    Apr 2021
    Posts
    27
    Thanks
    5

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    Quote Originally Posted by ChristianEhrlicher View Post
    Use an older QtCreator (not Qt btw) - QtCreator 4.15 is build with Qt5.15 which does not support this old CentOS - see https://doc.qt.io/qt-5/supported-platforms.html
    Thanks, Christian.

    On the Qt website, it says Qt 5 requires RHEL 7.6 to run.

    Is there a way to run Qt 5.12 on CentOS 6?

  9. #8
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    552
    Thanked 86 Times in 81 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Problem with installing Qt 4.15.1 on CentOS6

    I'm not sure - 5.12 needs at least RedHat 7.4: https://doc.qt.io/qt-5.12/supported-platforms.html

Similar Threads

  1. Replies: 0
    Last Post: 7th September 2015, 10:08
  2. Problem with installing Qt for uClinux
    By Evgeniy_SPB in forum Installation and Deployment
    Replies: 0
    Last Post: 14th November 2014, 12:49
  3. Problem with installing
    By Bloodcount in forum Newbie
    Replies: 2
    Last Post: 7th December 2012, 20:11
  4. Problem with installing Qt on XP
    By janK in forum Installation and Deployment
    Replies: 1
    Last Post: 11th September 2011, 20:54
  5. installing problem
    By mickey in forum Installation and Deployment
    Replies: 5
    Last Post: 24th September 2006, 20:30

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.