I try to run an application under WSL, but i crashes with
segment fault immediately.

In the stack trace, the last entry is
std::string::_M_assign(std::string const&)

-- main.cpp
int main(int argc, char *argv[])
QGuiApplication app(argc, argv);
QQmlApplicationEngine engine;

/* Start Application */
const QUrl url(u"qrc:/Test/Main.qml"_qs);
QObject::connect(&engine, &QQmlApplicationEngine:bjectCreated,
&app, [url](QObject *obj, const QUrl &objUrl) {
if (!obj && url == objUrl)
}, Qt::QueuedConnection);

return app.exec();
-- Main.qml
mport QtQuick
import QtQuick.Window
import QtQuick.Layouts
import QtQuick.Controls
import QtQuick.Dialogs

If I don't add anything, the window will open with the title.
If I add anything e.g. a label with text, then it crashes.

ApplicationWindow {
id: root

width: 876
height: 493
visible: true
title: qsTr("Acme")

Label {
id: topLabel

text: "Hello" // This line will cause segmentfault
color: "black"

- A pure widget app runs without problem.
- The Qt/Examples/Qt-6.5.3/demos/clocks crashes with same reason.
- I tried 6.5.3 and 6.7
- I tried both wayland and xcb
- I Run WSL2 and Ubuntu 22.04.3
- I build and run with qtcreator 13.0.0

Don't know what to try next. Would really appreciate some help.