Results 1 to 6 of 6

Thread: Fail to build debug libraries in QT4.3.2

  1. #1
    Join Date
    Oct 2007
    Posts
    32
    Thanks
    3
    Thanked 3 Times in 3 Posts
    Qt products
    Qt4
    Platforms
    Windows

    Default Fail to build debug libraries in QT4.3.2

    I try to build debug libraries in QT4.3.2 by click the shortcut after install QT package but get fail result. Here is the error message:

    Reading C:/Qt/4.3.2/demos/interview/interview.pro
    Reading C:/Qt/4.3.2/demos/mainwindow/mainwindow.pro
    Reading C:/Qt/4.3.2/demos/spreadsheet/spreadsheet.pro
    Reading C:/Qt/4.3.2/demos/textedit/textedit.pro
    Reading C:/Qt/4.3.2/demos/chip/chip.pro
    Reading C:/Qt/4.3.2/demos/undo/undo.pro
    Reading C:/Qt/4.3.2/demos/arthurplugin/arthurplugin.pro
    Reading C:/Qt/4.3.2/demos/sqlbrowser/sqlbrowser.pro
    Reading C:/Qt/4.3.2/demos/qtdemo/qtdemo.pro


    Qt is now configured for building. Just run mingw32-make.
    To reconfigure, run mingw32-make confclean and configure.

    (cd C:\Qt\4.3.2\src\winmain && mingw32-make -f Makefile debug)
    mingw32-make[1]: Entering directory `C:/Qt/4.3.2/src/winmain'
    mingw32-make -f Makefile.Debug
    mingw32-make[2]: Entering directory `C:/Qt/4.3.2/src/winmain'
    Makefile.Debug:116: *** multiple target patterns. Stop.
    mingw32-make[2]: Leaving directory `C:/Qt/4.3.2/src/winmain'
    mingw32-make[1]: *** [debug] Error 2
    mingw32-make[1]: Leaving directory `C:/Qt/4.3.2/src/winmain'
    mingw32-make: *** [debug-C__Qt_4_3_2_src_winmain] Error 2
    C:\Qt\4.3.2\src>

    My version of mingw: 3.4.2
    Can anybody tell me what's wrong and how to solve it? Thank you very much!

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: Fail to build debug libraries in QT4.3.2

    Try Christian Ehrlicher's advise in this thread: http://www.qtcentre.org/forum/f-qt-p...-431-8496.html
    J-P Nurmi

  3. #3
    Join Date
    Oct 2007
    Posts
    32
    Thanks
    3
    Thanked 3 Times in 3 Posts
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Fail to build debug libraries in QT4.3.2

    Thanks!

    After I remove the environment variable LIB, INCLUDE, I could build the debug libraries.

  4. The following user says thank you to SamT for this useful post:

    BrainB0ne (30th November 2007)

  5. #4
    Join Date
    Jan 2006
    Location
    Netherlands
    Posts
    56
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Windows

    Default Re: Fail to build debug libraries in QT4.3.2

    Quote Originally Posted by SamT View Post
    Thanks!

    After I remove the environment variable LIB, INCLUDE, I could build the debug libraries.
    Thanks dude! I was struggling with the same problem a long time!
    ..:: Still Standing Strong ::..

  6. #5

    Default Re: Fail to build debug libraries in QT4.3.2

    Unfortunately, I dont have these two variables set and have never installed MSVS... but I was getting bugged with the "multiple target patterns" error. I'm using cygwin with Wascana. I found the answer on this thread: http://dev.eclipse.org/newslists/new.../msg11764.html

    which essentially is this: When you specify your include path (or in your case the path to a lib), don't use C:/ use /cygdrive/c instead.

    Solved my problem

  7. #6
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    503
    Thanked 75 Times in 71 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Fail to build debug libraries in QT4.3.2

    Quote Originally Posted by zehawk View Post
    When you specify your include path (or in your case the path to a lib), don't use C:/ use /cygdrive/c instead.
    Or even better: Throw out cygwin and msys of your PATH - you don't need it to compile Qt

Similar Threads

  1. QWT fails in debug build
    By steg90 in forum Qwt
    Replies: 1
    Last Post: 11th November 2011, 07:53
  2. Adding custom defines when on debug build
    By chus in forum Qt Programming
    Replies: 2
    Last Post: 2nd March 2007, 12:38
  3. Replies: 11
    Last Post: 22nd March 2006, 20:06

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.